summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild')
-rw-r--r--app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild b/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild
index 072719a3ef24..b450f0c88e49 100644
--- a/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild,v 1.9 2010/09/02 14:53:21 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild,v 1.10 2010/09/13 08:44:13 fauli Exp $
EAPI=2
@@ -28,7 +28,7 @@ HOMEPAGE="http://www.gnu.org/software/emacs/"
LICENSE="GPL-3 FDL-1.3 BSD as-is MIT W3C unicode"
SLOT="24"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="alsa dbus gconf gif gpm gtk gzip-el hesiod imagemagick jpeg kerberos m17n-lib motif png sound source svg tiff toolkit-scroll-bars X Xaw3d xft +xpm"
+IUSE="alsa dbus gconf gif gpm gtk gzip-el hesiod imagemagick jpeg kerberos libxml2 m17n-lib motif png sound source svg tiff toolkit-scroll-bars X Xaw3d xft +xpm"
RESTRICT="strip"
RDEPEND="sys-libs/ncurses
@@ -44,6 +44,7 @@ RDEPEND="sys-libs/ncurses
x11-libs/libXt
x11-misc/xbitmaps
gconf? ( >=gnome-base/gconf-2.26.2 )
+ libxml2? ( >=dev-libs/libxml2-2.2.0 )
gif? ( media-libs/giflib )
jpeg? ( media-libs/jpeg:0 )
png? ( media-libs/libpng )
@@ -148,7 +149,7 @@ src_configure() {
if use X; then
myconf="${myconf} --with-x"
- myconf="${myconf} $(use_with gconf)"
+ myconf="${myconf} $(use_with gconf) $(use_with libxml2 xml2)"
myconf="${myconf} $(use_with toolkit-scroll-bars)"
myconf="${myconf} $(use_with gif) $(use_with jpeg)"
myconf="${myconf} $(use_with png) $(use_with svg rsvg)"