summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/pgadmin3')
-rw-r--r--dev-db/pgadmin3/ChangeLog7
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.10.5.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-db/pgadmin3/ChangeLog b/dev-db/pgadmin3/ChangeLog
index 87e27a2282a6..f7e62c1c3b1b 100644
--- a/dev-db/pgadmin3/ChangeLog
+++ b/dev-db/pgadmin3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/pgadmin3
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/ChangeLog,v 1.48 2010/07/11 18:47:45 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/ChangeLog,v 1.49 2010/08/30 20:18:21 patrick Exp $
+
+*pgadmin3-1.10.5 (30 Aug 2010)
+
+ 30 Aug 2010; Patrick Lauer <patrick@gentoo.org> +pgadmin3-1.10.5.ebuild:
+ Bump
11 Jul 2010; Raúl Porcel <armin76@gentoo.org> pgadmin3-1.10.2.ebuild:
alpha/sparc/x86 stable wrt #327045
diff --git a/dev-db/pgadmin3/pgadmin3-1.10.5.ebuild b/dev-db/pgadmin3/pgadmin3-1.10.5.ebuild
new file mode 100644
index 000000000000..fc03e03d971d
--- /dev/null
+++ b/dev-db/pgadmin3/pgadmin3-1.10.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/pgadmin3-1.10.5.ebuild,v 1.1 2010/08/30 20:18:21 patrick Exp $
+
+EAPI="2"
+
+WX_GTK_VER="2.8"
+
+inherit wxwidgets eutils autotools
+
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+
+DESCRIPTION="wxWidgets GUI for PostgreSQL."
+HOMEPAGE="http://www.pgadmin.org/"
+SRC_URI="mirror://postgresql/pgadmin3/release/v${PV}/src/${P}.tar.gz"
+LICENSE="Artistic"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="x11-libs/wxGTK:2.8[X]
+ dev-db/postgresql-base
+ >=dev-libs/libxml2-2.5
+ >=dev-libs/libxslt-1.1"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/1.8.2-as_needed_ssl_detect_broken.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-wx-version=2.8 \
+ $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "einstall failed"
+
+ insinto /usr/share/pixmaps
+ newins "${S}/pgadmin/include/images/elephant48.xpm" pgadmin3.xpm
+
+ insinto /usr/share/pgadmin3
+ newins "${S}/pgadmin/include/images/elephant48.xpm" pgadmin3.xpm
+
+ insinto /usr/share/applications
+ doins "${S}/pkg/pgadmin3.desktop"
+
+ # Fixing world-writable files
+ chmod -R go-w "${D}/usr/share"
+}