summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/edtftpj/edtftpj-1.3.3.ebuild')
-rw-r--r--dev-java/edtftpj/edtftpj-1.3.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-java/edtftpj/edtftpj-1.3.3.ebuild b/dev-java/edtftpj/edtftpj-1.3.3.ebuild
new file mode 100644
index 000000000000..734aeef6d6b9
--- /dev/null
+++ b/dev-java/edtftpj/edtftpj-1.3.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/edtftpj/edtftpj-1.3.3.ebuild,v 1.1 2004/05/21 19:26:00 zx Exp $
+
+inherit java-pkg
+
+DESCRIPTION="FTP client library written in Java"
+SRC_URI="http://www.enterprisedt.com/products/edtftpj/download/${P}.tar.gz"
+HOMEPAGE="http://www.enterprisedt.com"
+LICENSE="LGPL-2"
+KEYWORDS="~x86 ~sparc ~ppc"
+IUSE="jikes doc"
+DEPEND="virtual/jdk
+ >=dev-java/ant-1.5"
+RDEPEND="virtual/jdk"
+SLOT="0"
+RESTRICT="nomirror"
+
+src_compile() {
+ cd ${S}/src
+ local antflags="jar"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use doc && antflags="${antflags} javadocs"
+ ant ${antflags} || die "compilation failed"
+}
+
+src_install() {
+ cd ${S}
+ use doc && dohtml -r build/doc/api
+ dodoc doc/*.TXT
+ insinto /usr/share/doc/${PF}
+ doins doc/*.pdf
+
+ mv ${S}/build/${P}.jar ${S}/build/${PN}.jar
+ java-pkg_dojar build/${PN}.jar
+}