summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/ruby')
-rw-r--r--dev-lang/ruby/ChangeLog14
-rw-r--r--dev-lang/ruby/files/ruby-1.9.1_p129-gfbsd7.patch39
-rw-r--r--dev-lang/ruby/files/ruby-1.9.1_p129-no-undefined-ext.patch13
-rw-r--r--dev-lang/ruby/files/ruby-1.9.1_p129-parallelmake.patch14
-rw-r--r--dev-lang/ruby/files/ruby19-mkmf-parallel-install.patch13
-rw-r--r--dev-lang/ruby/files/ruby19-rubygems-gentoo.patch41
-rw-r--r--dev-lang/ruby/files/ruby19-rubygems-proxy.patch11
-rw-r--r--dev-lang/ruby/ruby-1.9.1_p129-r1.ebuild201
-rw-r--r--dev-lang/ruby/ruby-1.9.1_p243.ebuild (renamed from dev-lang/ruby/ruby-1.9.1_p129.ebuild)32
9 files changed, 28 insertions, 350 deletions
diff --git a/dev-lang/ruby/ChangeLog b/dev-lang/ruby/ChangeLog
index 50e17fa044dd..05f7a0005742 100644
--- a/dev-lang/ruby/ChangeLog
+++ b/dev-lang/ruby/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for dev-lang/ruby
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.420 2009/08/20 09:09:50 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.421 2009/09/09 14:47:04 a3li Exp $
+
+*ruby-1.9.1_p243 (09 Sep 2009)
+
+ 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
+ -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
+ -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
+ -files/ruby-1.9.1_p129-no-undefined-ext.patch,
+ -files/ruby19-rubygems-proxy.patch,
+ -files/ruby-1.9.1_p129-parallelmake.patch,
+ -files/ruby19-mkmf-parallel-install.patch:
+ Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
+ 168939. Cleaning up old patches.
*ruby-1.8.6_p383 (20 Aug 2009)
diff --git a/dev-lang/ruby/files/ruby-1.9.1_p129-gfbsd7.patch b/dev-lang/ruby/files/ruby-1.9.1_p129-gfbsd7.patch
deleted file mode 100644
index f4d567ae40c4..000000000000
--- a/dev-lang/ruby/files/ruby-1.9.1_p129-gfbsd7.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-Index: ruby-1.9.1-p129/configure.in
-===================================================================
---- ruby-1.9.1-p129.orig/configure.in
-+++ ruby-1.9.1-p129/configure.in
-@@ -1294,7 +1294,7 @@ if test "$rb_cv_binary_elf" = yes; then
- fi
-
- case "$target_os" in
--linux* | gnu* | k*bsd*-gnu | bsdi*)
-+linux* | gnu* | k*bsd*-gnu | bsdi* | freebsd* | dragonfly* )
- if test "$rb_cv_binary_elf" = no; then
- with_dln_a_out=yes
- else
-@@ -1381,7 +1381,7 @@ if test "$with_dln_a_out" != yes; then
- *shlicc*) : ${LDSHARED="$CC -r"}
- rb_cv_dlopen=yes ;;
- esac ;;
-- linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi*)
-+ linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | freebsd7*)
- : ${LDSHARED='${CC} -shared'}
- if test "$rb_cv_binary_elf" = yes; then
- LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
-@@ -1393,7 +1393,6 @@ if test "$with_dln_a_out" != yes; then
- rb_cv_dlopen=yes ;;
- freebsd*|dragonfly*) : ${LDSHARED="$CC -shared"}
- if test "$rb_cv_binary_elf" = yes; then
-- LDFLAGS="$LDFLAGS -rdynamic"
- DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$(.TARGET)'
- else
- test "$GCC" = yes && test "$rb_cv_prog_gnu_ld" = yes || LDSHARED="ld -Bshareable"
-@@ -1722,7 +1721,7 @@ if test "$enable_shared" = 'yes'; then
- sunos4*)
- LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_SO_NAME).so'
- ;;
-- linux* | gnu* | k*bsd*-gnu | atheos*)
-+ linux* | gnu* | k*bsd*-gnu | atheos* | freebsd7* )
- LIBRUBY_DLDFLAGS='-Wl,-soname,lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR)'
- LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_SO_NAME).so'
- ;;
diff --git a/dev-lang/ruby/files/ruby-1.9.1_p129-no-undefined-ext.patch b/dev-lang/ruby/files/ruby-1.9.1_p129-no-undefined-ext.patch
deleted file mode 100644
index 08d1876425ca..000000000000
--- a/dev-lang/ruby/files/ruby-1.9.1_p129-no-undefined-ext.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: ruby-1.9.1-p129/configure.in
-===================================================================
---- ruby-1.9.1-p129.orig/configure.in
-+++ ruby-1.9.1-p129/configure.in
-@@ -1384,7 +1384,7 @@ if test "$with_dln_a_out" != yes; then
- linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | freebsd7*)
- : ${LDSHARED='${CC} -shared'}
- if test "$rb_cv_binary_elf" = yes; then
-- LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
-+ LDFLAGS="$LDFLAGS -Wl,-export-dynamic -Wl,--no-undefined"
- fi
- rb_cv_dlopen=yes ;;
- interix*) : ${LDSHARED="$CC -shared"}
diff --git a/dev-lang/ruby/files/ruby-1.9.1_p129-parallelmake.patch b/dev-lang/ruby/files/ruby-1.9.1_p129-parallelmake.patch
deleted file mode 100644
index 60f08d745ff4..000000000000
--- a/dev-lang/ruby/files/ruby-1.9.1_p129-parallelmake.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Index: ruby-1.9.1-p129/ext/dl/depend
-===================================================================
---- ruby-1.9.1-p129.orig/ext/dl/depend
-+++ ruby-1.9.1-p129/ext/dl/depend
-@@ -18,7 +18,8 @@ callback-8.o: callback-8.c $(hdrdir)/rub
-
- callback-0.c callback-1.c callback-2.c \
- callback-3.c callback-4.c callback-5.c \
--callback-6.c callback-7.c callback-8.c \
-+callback-6.c callback-7.c callback-8.c: callback.h
-+
- callback.h: $(srcdir)/mkcallback.rb dl.h
- @echo "generating callback.h"
- @$(RUBY) $(srcdir)/mkcallback.rb $(srcdir)/dl.h
diff --git a/dev-lang/ruby/files/ruby19-mkmf-parallel-install.patch b/dev-lang/ruby/files/ruby19-mkmf-parallel-install.patch
deleted file mode 100644
index d0652484dbe4..000000000000
--- a/dev-lang/ruby/files/ruby19-mkmf-parallel-install.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Patch for bug 239101 by Matsuu Takuto, via Redmine issue 1337 (yes, really).
-
---- lib/mkmf.rb (revision 23101)
-+++ lib/mkmf.rb (working copy)
-@@ -1710,7 +1710,7 @@
- mfile.print "\t@-$(RM) #{fseprepl[dest]}\n"
- mfile.print "\t@-$(RMDIRS) #{fseprepl[dir]}\n"
- else
-- mfile.print "#{dest}: #{f}\n"
-+ mfile.print "#{dest}: #{dir} #{f}\n"
- mfile.print "\t$(INSTALL_PROG) #{fseprepl[f]} #{fseprepl[dir]}\n"
- if defined?($installed_list)
- mfile.print "\t@echo #{dir}/#{File.basename(f)}>>$(INSTALLED_LIST)\n"
diff --git a/dev-lang/ruby/files/ruby19-rubygems-gentoo.patch b/dev-lang/ruby/files/ruby19-rubygems-gentoo.patch
deleted file mode 100644
index 754d663c8009..000000000000
--- a/dev-lang/ruby/files/ruby19-rubygems-gentoo.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-diff -ru a/lib/rubygems/commands/install_command.rb b/lib/rubygems/commands/install_command.rb
---- a/lib/rubygems/commands/install_command.rb 2008-09-11 01:54:41.000000000 +0200
-+++ b/lib/rubygems/commands/install_command.rb 2008-09-28 10:24:27.000000000 +0200
-@@ -76,6 +76,7 @@
- :wrappers => options[:wrappers],
- :bin_dir => options[:bin_dir],
- :development => options[:development],
-+ :sandbox_fix => options[:sandbox_fix],
- }
-
- exit_code = 0
-diff -ru a/lib/rubygems/dependency_installer.rb b/lib/rubygems/dependency_installer.rb
---- a/lib/rubygems/dependency_installer.rb 2008-08-12 23:50:22.000000000 +0200
-+++ b/lib/rubygems/dependency_installer.rb 2008-09-28 10:22:21.000000000 +0200
-@@ -40,9 +40,10 @@
- # :security_policy:: See Gem::Installer::new and Gem::Security.
- # :user_install:: See Gem::Installer.new
- # :wrappers:: See Gem::Installer::new
-+ # :sandbox_fix:: Gentoo patch to repair compatibility
-
- def initialize(options = {})
-- if options[:install_dir] then
-+ if options[:install_dir] and not options[:sandbox_fix] then
- spec_dir = options[:install_dir], 'specifications'
- @source_index = Gem::SourceIndex.from_gems_in spec_dir
- else
-diff -ru a/lib/rubygems/install_update_options.rb b/lib/rubygems/install_update_options.rb
---- a/lib/rubygems/install_update_options.rb 2008-06-24 20:56:30.000000000 +0200
-+++ b/lib/rubygems/install_update_options.rb 2008-09-28 10:24:09.000000000 +0200
-@@ -83,6 +83,11 @@
- options[:include_dependencies] = value
- end
-
-+ add_option(:"Install/Update", '--sandbox-fix',
-+ 'Fix specifications lookup path [Gentoo patch]') do |value, options|
-+ options[:sandbox_fix] = true
-+ end
-+
- add_option(:"Install/Update", '--[no-]format-executable',
- 'Make installed executable names match ruby.',
- 'If ruby is ruby18, foo_exec will be',
diff --git a/dev-lang/ruby/files/ruby19-rubygems-proxy.patch b/dev-lang/ruby/files/ruby19-rubygems-proxy.patch
deleted file mode 100644
index c1719ccdef14..000000000000
--- a/dev-lang/ruby/files/ruby19-rubygems-proxy.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/rubygems/remote_fetcher.rb.1 2008-06-21 23:21:17.000000000 +0200
-+++ lib/rubygems/remote_fetcher.rb 2008-09-23 20:37:24.000000000 +0200
-@@ -195,7 +195,7 @@
-
- return nil if env_proxy.nil? or env_proxy.empty?
-
-- uri = URI.parse env_proxy
-+ uri = URI.parse normalize_uri env_proxy
-
- if uri and uri.user.nil? and uri.password.nil? then
- # Probably we have http_proxy_* variables?
diff --git a/dev-lang/ruby/ruby-1.9.1_p129-r1.ebuild b/dev-lang/ruby/ruby-1.9.1_p129-r1.ebuild
deleted file mode 100644
index fc7f914eacfa..000000000000
--- a/dev-lang/ruby/ruby-1.9.1_p129-r1.ebuild
+++ /dev/null
@@ -1,201 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.9.1_p129-r1.ebuild,v 1.3 2009/07/31 17:12:43 ssuominen Exp $
-
-EAPI=2
-
-inherit autotools eutils flag-o-matic multilib versionator
-
-# Add p0 patchlevel
-MY_P="${P/_/-}"
-
-# 1.9.1.0 -> 1.9
-SLOT=$(get_version_component_range 1-2)
-
-# 1.9.1.0 -> 1.9.1 (used in libdirs)
-RUBYVERSION=$(get_version_component_range 1-3)
-
-# 1.9 -> 19
-MY_SUFFIX=$(delete_version_separator 1 ${SLOT})
-
-DESCRIPTION="An object-oriented scripting language"
-HOMEPAGE="http://www.ruby-lang.org/"
-SRC_URI="mirror://ruby/${MY_P}.tar.bz2"
-
-LICENSE="|| ( Ruby GPL-2 )"
-KEYWORDS="~amd64 ~x86 ~x86-fbsd"
-IUSE="+berkdb debug doc emacs examples +gdbm ipv6 rubytests socks5 ssl tk xemacs"
-
-RDEPEND="
- berkdb? ( sys-libs/db )
- gdbm? ( sys-libs/gdbm )
- ssl? ( dev-libs/openssl )
- socks5? ( >=net-proxy/dante-1.1.13 )
- tk? ( dev-lang/tk[threads] )
- >=app-admin/eselect-ruby-20080921
- !=dev-lang/ruby-cvs-${SLOT}*
- !<dev-ruby/rdoc-2
- !dev-ruby/rexml"
-DEPEND="${RDEPEND}"
-PDEPEND="
- emacs? ( app-emacs/ruby-mode )
- xemacs? ( app-xemacs/ruby-modes )"
-
-PROVIDE="virtual/ruby"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- ewarn
- ewarn "It is highly recommended to install >=dev-ruby/rubygems-1.3.1-r30"
- ewarn "if you have Ruby 1.8 on this system installed, too."
- ewarn
- epause 5
-}
-
-src_prepare() {
- cd "${S}"
-
- # Patch wrt bug #238061
- epatch "${FILESDIR}/ruby19-rubygems-proxy.patch"
- # Patch for rubygems to find installed gems outside of the sandbox
- epatch "${FILESDIR}/ruby19-rubygems-gentoo.patch"
-
- epatch "${FILESDIR}/${PN}${MY_SUFFIX}-mkmf-parallel-install.patch"
-
- epatch "${FILESDIR}"/${P}-gfbsd7.patch
- epatch "${FILESDIR}"/${P}-no-undefined-ext.patch
- epatch "${FILESDIR}"/${P}-parallelmake.patch
-
- # Strip rake
- rm "bin/rake"
- rm "lib/rake.rb"
- rm -rf "lib/rake"
-
- # Fix a hardcoded lib path in configure script
- sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \
- configure.in || die "sed failed"
-
- eautoreconf
-}
-
-src_configure() {
- # -fomit-frame-pointer makes ruby segfault, see bug #150413.
- filter-flags -fomit-frame-pointer
- # In many places aliasing rules are broken; play it safe
- # as it's risky with newer compilers to leave it as it is.
- append-flags -fno-strict-aliasing
-
- # Socks support via dante
- if use socks5 ; then
- # Socks support can't be disabled as long as SOCKS_SERVER is
- # set and socks library is present, so need to unset
- # SOCKS_SERVER in that case.
- unset SOCKS_SERVER
- fi
-
- # Increase GC_MALLOC_LIMIT if set (default is 8000000)
- if [ -n "${RUBY_GC_MALLOC_LIMIT}" ] ; then
- append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
- fi
-
- econf --program-suffix=${MY_SUFFIX} --enable-shared --enable-pthread \
- $(use_enable socks5 socks) \
- $(use_enable doc install-doc) \
- $(use_enable ipv6) \
- $(use_enable debug) \
- $(use_with berkdb dbm) \
- $(use_with gdbm) \
- $(use_with ssl openssl) \
- $(use_with tk) \
- ${myconf} \
- --enable-option-checking=no \
- || die "econf failed"
-}
-
-src_compile() {
- emake EXTLDFLAGS="${LDFLAGS}" || die "emake failed"
-}
-
-src_test() {
- emake test || die "make test failed"
-
- elog "Ruby's make test has been run. Ruby also ships with a make check"
- elog "that cannot be run until after ruby has been installed."
- elog
- if use rubytests; then
- elog "You have enabled rubytests, so they will be installed to"
- elog "/usr/share/${PN}-${RUBYVERSION}/test. To run them you must be a user other"
- elog "than root, and you must place them into a writeable directory."
- elog "Then call: "
- elog
- elog "ruby19 -C /location/of/tests runner.rb"
- else
- elog "Enable the rubytests USE flag to install the make check tests"
- fi
-}
-
-src_install() {
- # Ruby is involved in the install process, we don't want interference here.
- unset RUBYOPT
-
- # Creating the rubygems directories, bug #230163 once more.
- local MINIRUBY=$(echo -e 'include Makefile\ngetminiruby:\n\t@echo $(MINIRUBY)'|make -f - getminiruby)
- keepdir /usr/$(get_libdir)/ruby${MY_SUFFIX}/gems/${RUBYVERSION}/{doc,gems,cache,specifications}
-
- export GEM_HOME="${D}/usr/$(get_libdir)/ruby${MY_SUFFIX}/gems/${RUBYVERSION}"
- export GEM_PATH="${GEM_HOME}/"
-
- LD_LIBRARY_PATH="${D}/usr/$(get_libdir)${LD_LIBRARY_PATH+:}${LD_LIBRARY_PATH}"
- RUBYLIB="${S}:${D}/usr/$(get_libdir)/ruby/${RUBYVERSION}"
- for d in $(find "${S}/ext" -type d) ; do
- RUBYLIB="${RUBYLIB}:$d"
- done
- export LD_LIBRARY_PATH RUBYLIB
-
- emake DESTDIR="${D}" install || die "make install failed"
-
- keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitelibdir']")
- keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitearchdir']")
-
- if use doc; then
- make DESTDIR="${D}" install-doc || die "make install-doc failed"
- fi
-
- if use examples; then
- dodir /usr/share/doc/${PF}
- cp -pPR sample "${D}/usr/share/doc/${PF}"
- fi
-
- dosym "libruby${MY_SUFFIX}$(get_libname ${PV%_*})" \
- "/usr/$(get_libdir)/libruby$(get_libname ${PV%.*})"
- dosym "libruby${MY_SUFFIX}$(get_libname ${PV%_*})" \
- "/usr/$(get_libdir)/libruby$(get_libname ${PV%_*})"
-
- dodoc ChangeLog NEWS doc/NEWS-1.8.7 README* ToDo
-
- if use rubytests; then
- dodir /usr/share/${PN}-${RUBYVERSION}
- cp -pPR test "${D}/usr/share/${PN}-${RUBYVERSION}"
- fi
-
- insinto /usr/$(get_libdir)/ruby${MY_SUFFIX}/site_ruby/
- newins "${FILESDIR}/auto_gem.rb" auto_gem.rb
-}
-
-pkg_postinst() {
- if [[ ! -n $(readlink "${ROOT}"usr/bin/ruby) ]] ; then
- eselect ruby set ruby${MY_SUFFIX}
- fi
-
- elog
- elog "To switch between available Ruby profiles, execute as root:"
- elog "\teselect ruby set ruby(18|19|...)"
- elog
-}
-
-pkg_postrm() {
- if [[ ! -n $(readlink "${ROOT}"usr/bin/ruby) ]] ; then
- eselect ruby set ruby${MY_SUFFIX}
- fi
-}
diff --git a/dev-lang/ruby/ruby-1.9.1_p129.ebuild b/dev-lang/ruby/ruby-1.9.1_p243.ebuild
index d68395cc11e3..cca7de61928e 100644
--- a/dev-lang/ruby/ruby-1.9.1_p129.ebuild
+++ b/dev-lang/ruby/ruby-1.9.1_p243.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.9.1_p129.ebuild,v 1.4 2009/07/31 17:12:43 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.9.1_p243.ebuild,v 1.1 2009/09/09 14:47:04 a3li Exp $
EAPI=2
inherit autotools eutils flag-o-matic multilib versionator
-# Add p0 patchlevel
+# Add patchlevel
MY_P="${P/_/-}"
# 1.9.1.0 -> 1.9
@@ -20,11 +20,12 @@ MY_SUFFIX=$(delete_version_separator 1 ${SLOT})
DESCRIPTION="An object-oriented scripting language"
HOMEPAGE="http://www.ruby-lang.org/"
-SRC_URI="mirror://ruby/${MY_P}.tar.bz2"
+SRC_URI="mirror://ruby/${MY_P}.tar.bz2
+ http://dev.a3li.info/gentoo/distfiles/${PN}-patches-${PVR}.tar.bz2"
LICENSE="|| ( Ruby GPL-2 )"
KEYWORDS="~amd64 ~x86 ~x86-fbsd"
-IUSE="+berkdb debug doc emacs examples +gdbm ipv6 rubytests socks5 ssl tk xemacs"
+IUSE="berkdb debug doc emacs examples gdbm ipv6 rubytests socks5 ssl tk xemacs"
RDEPEND="
berkdb? ( sys-libs/db )
@@ -32,7 +33,7 @@ RDEPEND="
ssl? ( dev-libs/openssl )
socks5? ( >=net-proxy/dante-1.1.13 )
tk? ( dev-lang/tk[threads] )
- >=app-admin/eselect-ruby-20080921
+ >=app-admin/eselect-ruby-20090909
!=dev-lang/ruby-cvs-${SLOT}*
!<dev-ruby/rdoc-2
!dev-ruby/rexml"
@@ -56,12 +57,8 @@ pkg_setup() {
src_prepare() {
cd "${S}"
- # Patch wrt bug #238061
- epatch "${FILESDIR}/ruby19-rubygems-proxy.patch"
- # Patch for rubygems to find installed gems outside of the sandbox
- epatch "${FILESDIR}/ruby19-rubygems-gentoo.patch"
-
- epatch "${FILESDIR}/${PN}${MY_SUFFIX}-mkmf-parallel-install.patch"
+ EPATCH_FORCE="yes" EPATCH_SUFFIX="patch" \
+ epatch "${WORKDIR}/patches-${PVR}"
# Strip rake
rm "bin/rake"
@@ -95,10 +92,13 @@ src_configure() {
append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
fi
+ # ipv6 hack, bug 168939. Needs --enable-ipv6.
+ use ipv6 || myconf="--with-lookup-order-hack=INET"
+
econf --program-suffix=${MY_SUFFIX} --enable-shared --enable-pthread \
$(use_enable socks5 socks) \
$(use_enable doc install-doc) \
- $(use_enable ipv6) \
+ --enable-ipv6 \
$(use_enable debug) \
$(use_with berkdb dbm) \
$(use_with gdbm) \
@@ -142,7 +142,7 @@ src_install() {
export GEM_HOME="${D}/usr/$(get_libdir)/ruby${MY_SUFFIX}/gems/${RUBYVERSION}"
export GEM_PATH="${GEM_HOME}/"
- LD_LIBRARY_PATH="${D}/usr/$(get_libdir)"
+ LD_LIBRARY_PATH="${D}/usr/$(get_libdir)${LD_LIBRARY_PATH+:}${LD_LIBRARY_PATH}"
RUBYLIB="${S}:${D}/usr/$(get_libdir)/ruby/${RUBYVERSION}"
for d in $(find "${S}/ext" -type d) ; do
RUBYLIB="${RUBYLIB}:$d"
@@ -175,7 +175,7 @@ src_install() {
cp -pPR test "${D}/usr/share/${PN}-${RUBYVERSION}"
fi
- insinto /usr/$(get_libdir)/ruby${MY_SUFFIX}/site_ruby/
+ insinto /usr/$(get_libdir)/ruby${MY_SUFFIX}/vendor_ruby/${RUBYVERSION}/
newins "${FILESDIR}/auto_gem.rb" auto_gem.rb
}
@@ -191,7 +191,5 @@ pkg_postinst() {
}
pkg_postrm() {
- if [[ ! -n $(readlink "${ROOT}"usr/bin/ruby) ]] ; then
- eselect ruby set ruby${MY_SUFFIX}
- fi
+ eselect ruby cleanup
}