summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/SGMLSpm')
-rw-r--r--dev-perl/SGMLSpm/ChangeLog10
-rw-r--r--dev-perl/SGMLSpm/SGMLSpm-1.03-r6.ebuild27
-rw-r--r--dev-perl/SGMLSpm/files/Makefile.PL17
-rw-r--r--dev-perl/SGMLSpm/files/sgmlspl.patch11
4 files changed, 63 insertions, 2 deletions
diff --git a/dev-perl/SGMLSpm/ChangeLog b/dev-perl/SGMLSpm/ChangeLog
index 41b9a47bc6fb..5d6bc6f43a93 100644
--- a/dev-perl/SGMLSpm/ChangeLog
+++ b/dev-perl/SGMLSpm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/SGMLSpm
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/SGMLSpm/ChangeLog,v 1.32 2007/07/12 08:45:04 uberlord Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SGMLSpm/ChangeLog,v 1.33 2008/08/23 15:55:05 tove Exp $
+
+*SGMLSpm-1.03-r6 (23 Aug 2008)
+
+ 23 Aug 2008; Torsten Veller <tove@gentoo.org> +files/Makefile.PL,
+ +files/sgmlspl.patch, +SGMLSpm-1.03-r6.ebuild:
+ Simplify the ebuild: Use Makefile.PL from debian. Fixes #209608.
12 Jul 2007; Roy Marples <uberlord@gentoo.org> SGMLSpm-1.03-r5.ebuild:
Keyworded ~sparc-fbsd
diff --git a/dev-perl/SGMLSpm/SGMLSpm-1.03-r6.ebuild b/dev-perl/SGMLSpm/SGMLSpm-1.03-r6.ebuild
new file mode 100644
index 000000000000..baf274326f26
--- /dev/null
+++ b/dev-perl/SGMLSpm/SGMLSpm-1.03-r6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SGMLSpm/SGMLSpm-1.03-r6.ebuild,v 1.1 2008/08/23 15:55:05 tove Exp $
+
+inherit eutils perl-module
+
+MY_P="${P}ii"
+S=${WORKDIR}/${PN}
+
+DESCRIPTION="Perl library for parsing the output of nsgmls"
+HOMEPAGE="http://search.cpan.org/author/DMEGG/SGMLSpm-1.03ii/"
+SRC_URI="mirror://cpan/authors/id/D/DM/DMEGG/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+mydoc="TODO BUGS"
+
+src_unpack() {
+ unpack ${A}
+ cp "${FILESDIR}"/Makefile.PL "${S}"/Makefile.PL
+ epatch "${FILESDIR}"/sgmlspl.patch
+ mv "${S}"/sgmlspl{.pl,}
+}
diff --git a/dev-perl/SGMLSpm/files/Makefile.PL b/dev-perl/SGMLSpm/files/Makefile.PL
new file mode 100644
index 000000000000..a2508c0a9afb
--- /dev/null
+++ b/dev-perl/SGMLSpm/files/Makefile.PL
@@ -0,0 +1,17 @@
+use ExtUtils::MakeMaker;
+# See lib/ExtUtils/MakeMaker.pm for details of how to influence
+# the contents of the Makefile that is written.
+WriteMakefile(
+ 'NAME' => 'SGMLS',
+ 'VERSION' => '1.03ii',
+ 'PM' => { 'SGMLS.pm' => '$(INST_LIBDIR)/SGMLS.pm',
+ 'Output.pm' => '$(INST_LIBDIR)/SGMLS/Output.pm',
+ 'Refs.pm' => '$(INST_LIBDIR)/SGMLS/Refs.pm',
+ 'skel.pl' => '$(INST_LIBDIR)/sgmlspl-specs/skel.pl',
+ },
+ 'MAN3PODS'=> { 'SGMLS.pm' => '$(INST_MAN3DIR)/SGMLS.3pm',
+ 'Output.pm' => '$(INST_MAN3DIR)/SGMLS::Output.3pm',
+ 'Refs.pm' => '$(INST_MAN3DIR)/SGMLS::Refs.3pm',
+ },
+ 'EXE_FILES' => [ 'sgmlspl', ],
+);
diff --git a/dev-perl/SGMLSpm/files/sgmlspl.patch b/dev-perl/SGMLSpm/files/sgmlspl.patch
new file mode 100644
index 000000000000..946ce319a97d
--- /dev/null
+++ b/dev-perl/SGMLSpm/files/sgmlspl.patch
@@ -0,0 +1,11 @@
+--- SGMLSpm/sgmlspl.pl.old 2008-08-23 17:06:13.000000000 +0200
++++ SGMLSpm/sgmlspl.pl 2008-08-23 17:07:13.000000000 +0200
+@@ -238,7 +238,7 @@
+ package main;
+
+ $ARGV = shift;
+-unless ($ARGV eq '' || do $ARGV) {
++unless ($ARGV eq '' || do 'sgmlspl-specs/' . $ARGV || do $ARGV) {
+ if (!-e $ARGV) {
+ die "FATAL: $ARGV does not exist.\n";
+ } elsif (!-r $ARGV) {