summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/chaco')
-rw-r--r--dev-python/chaco/ChangeLog8
-rw-r--r--dev-python/chaco/chaco-3.3.2.ebuild87
2 files changed, 94 insertions, 1 deletions
diff --git a/dev-python/chaco/ChangeLog b/dev-python/chaco/ChangeLog
index bc79c874cae2..22ea72f1b621 100644
--- a/dev-python/chaco/ChangeLog
+++ b/dev-python/chaco/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/chaco
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/chaco/ChangeLog,v 1.8 2010/08/04 23:28:21 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chaco/ChangeLog,v 1.9 2010/10/18 14:51:00 arfrever Exp $
+
+*chaco-3.3.2 (18 Oct 2010)
+
+ 18 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -chaco-3.3.1.ebuild, +chaco-3.3.2.ebuild:
+ Version bump.
05 Aug 2010; Sébastien Fabbro <bicatali@gentoo.org> chaco-3.3.1.ebuild:
Added virtualx for documentation generation, bug #330517
diff --git a/dev-python/chaco/chaco-3.3.2.ebuild b/dev-python/chaco/chaco-3.3.2.ebuild
new file mode 100644
index 000000000000..6d4159ba04e3
--- /dev/null
+++ b/dev-python/chaco/chaco-3.3.2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chaco/chaco-3.3.2.ebuild,v 1.1 2010/10/18 14:51:01 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils virtualx
+
+MY_PN="Chaco"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Interactive plotting toolkit"
+HOMEPAGE="http://code.enthought.com/projects/chaco http://pypi.python.org/pypi/Chaco"
+SRC_URI="http://www.enthought.com/repo/ETS/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/enable-3.3.2
+ >=dev-python/enthoughtbase-3.0.6
+ dev-python/numpy"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ doc? ( dev-python/setupdocs
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ x11-apps/xhost )
+ test? (
+ dev-python/coverage
+ >=dev-python/nose-0.10.3
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ x11-apps/xhost
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+PYTHON_MODNAME="enthought"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # "${S}/enthought/chaco2/tests does not exist.
+ sed -e "s:,enthought/chaco2/tests::" -i setup.cfg || die "sed setup.cfg failed"
+
+ sed \
+ -e "s/self.run_command('build_docs')/pass/" \
+ -e "/setupdocs>=1.0/d" \
+ -i setup.py || die "sed setup.py failed"
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ doc_generation() {
+ "$(PYTHON -f)" setup.py build_docs --formats=html,pdf || die "Generation of documentation failed"
+ }
+ maketype="doc_generation" virtualmake
+ fi
+}
+
+src_test() {
+ maketype="distutils_src_test" virtualmake
+}
+
+src_install() {
+ find "${S}" -name "*LICENSE.txt" -delete
+ distutils_src_install
+ dodoc docs/*.txt
+ insinto /usr/share/doc/${PF}
+ if use doc; then
+ doins -r build/docs/html build/docs/latex/*.pdf || die
+ fi
+ if use examples; then
+ doins -r examples || die
+ fi
+}