summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gdl-python/gdl-python-2.25.3.ebuild')
-rw-r--r--dev-python/gdl-python/gdl-python-2.25.3.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-python/gdl-python/gdl-python-2.25.3.ebuild b/dev-python/gdl-python/gdl-python-2.25.3.ebuild
index 9e5d837a25a3..32aac4e49a45 100644
--- a/dev-python/gdl-python/gdl-python-2.25.3.ebuild
+++ b/dev-python/gdl-python/gdl-python-2.25.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gdl-python/gdl-python-2.25.3.ebuild,v 1.9 2011/02/26 19:22:50 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdl-python/gdl-python-2.25.3.ebuild,v 1.10 2012/08/13 09:25:56 tetromino Exp $
EAPI="2"
G_PY_PN="gnome-python-extras"
@@ -9,7 +9,7 @@ SUPPORT_PYTHON_ABIS="1"
PYTHON_DEPEND="2"
RESTRICT_PYTHON_ABIS="3.*"
-inherit gnome-python-common
+inherit autotools eutils gnome-python-common
PVP="$(get_version_component_range 1-2)"
SRC_URI="mirror://gnome/sources/${G_PY_PN}/${PVP}/${G_PY_PN}-${PV}.tar.bz2"
@@ -21,13 +21,18 @@ KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="examples"
RDEPEND=">=dev-libs/gdl-2.28:1"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ gnome-base/gnome-common"
+# eautoreconf needs gnome-base/gnome-common
EXAMPLES="examples/gdl/*"
src_prepare() {
# Fix build failure with gdl-2.28
epatch "${FILESDIR}/${PN}-2.19.1-gdlapi-removal.patch"
+ epatch "${FILESDIR}/${P}-python-libs.patch" #344231
+ eautoreconf
gnome-python-common_src_prepare
}