summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/routes/routes-1.6.3.ebuild')
-rw-r--r--dev-python/routes/routes-1.6.3.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/routes/routes-1.6.3.ebuild b/dev-python/routes/routes-1.6.3.ebuild
deleted file mode 100644
index f0455bd09188..000000000000
--- a/dev-python/routes/routes-1.6.3.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/routes/routes-1.6.3.ebuild,v 1.2 2007/07/04 20:21:18 lucass Exp $
-
-NEED_PYTHON=2.4
-
-inherit distutils
-
-KEYWORDS="~amd64 ~x86"
-
-MY_PN=Routes
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="A Python re-implementation of the Rails routes system for mapping URL's to Controllers/Actions."
-HOMEPAGE="http://routes.groovie.org"
-SRC_URI="http://cheeseshop.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc test"
-
-DEPEND="doc? ( dev-python/buildutils dev-python/pudge )
- test? ( dev-python/nose )
- dev-python/setuptools"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-src_compile() {
- distutils_src_compile
- if use doc ; then
- einfo "Generating docs as requested..."
- PYTHONPATH=. "${python}" setup.py pudge || die "generating docs failed"
- fi
-}
-
-src_install() {
- distutils_src_install
- use doc && dohtml -r docs/html/*
-}
-
-src_test() {
- PYTHONPATH=. "${python}" setup.py test || die "test failed"
-}