summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/activemodel/activemodel-3.0.19.ebuild')
-rw-r--r--dev-ruby/activemodel/activemodel-3.0.19.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-ruby/activemodel/activemodel-3.0.19.ebuild b/dev-ruby/activemodel/activemodel-3.0.19.ebuild
deleted file mode 100644
index 45c48f2f5084..000000000000
--- a/dev-ruby/activemodel/activemodel-3.0.19.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-3.0.19.ebuild,v 1.1 2013/01/09 09:16:37 graaff Exp $
-
-EAPI=4
-
-USE_RUBY="ruby18 ree18"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
-HOMEPAGE="http://github.com/rails/rails"
-SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="3.0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RUBY_S="rails-rails-*/activemodel"
-
-ruby_add_rdepend "
- ~dev-ruby/activesupport-${PV}
- >=dev-ruby/builder-2.1.2
- >=dev-ruby/i18n-0.5.0:0.5"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/ruby-debug
- >=dev-ruby/mocha-0.9.5
- virtual/ruby-test-unit
- )"
-
-all_ruby_prepare() {
- # Set test environment to our hand.
- rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
- sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
-}