summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/gltron')
-rw-r--r--games-action/gltron/ChangeLog7
-rw-r--r--games-action/gltron/files/digest-gltron-0.70-r1 (renamed from games-action/gltron/files/digest-gltron-0.70)0
-rw-r--r--games-action/gltron/files/gltron-0.70-debian.patch35
-rw-r--r--games-action/gltron/gltron-0.70-r1.ebuild (renamed from games-action/gltron/gltron-0.70.ebuild)3
4 files changed, 42 insertions, 3 deletions
diff --git a/games-action/gltron/ChangeLog b/games-action/gltron/ChangeLog
index 2c110af660d2..2b022dfc01b6 100644
--- a/games-action/gltron/ChangeLog
+++ b/games-action/gltron/ChangeLog
@@ -1,10 +1,13 @@
# ChangeLog for games-action/gltron
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/ChangeLog,v 1.9 2005/07/30 04:37:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/ChangeLog,v 1.10 2005/07/30 04:53:52 vapier Exp $
+
+*gltron-0.70-r1 (30 Jul 2005)
30 Jul 2005; Mike Frysinger <vapier@gentoo.org>
+files/gltron-0.70-configure.patch, +files/gltron-0.70-prototypes.patch,
- gltron-0.70.ebuild:
+ +files/gltron-0.70-debian.patch, +gltron-0.70-r1.ebuild:
+ Add fixes from Debian for amd64 support #100109 Micha Wiernowolski.
Fix CFLAGS breakage and sync some mismatched prototypes.
31 May 2005; Marcus D. Hanwell <marcus@gentoo.org> gltron-0.70.ebuild:
diff --git a/games-action/gltron/files/digest-gltron-0.70 b/games-action/gltron/files/digest-gltron-0.70-r1
index 35454d6685d1..35454d6685d1 100644
--- a/games-action/gltron/files/digest-gltron-0.70
+++ b/games-action/gltron/files/digest-gltron-0.70-r1
diff --git a/games-action/gltron/files/gltron-0.70-debian.patch b/games-action/gltron/files/gltron-0.70-debian.patch
new file mode 100644
index 000000000000..464cf5928207
--- /dev/null
+++ b/games-action/gltron/files/gltron-0.70-debian.patch
@@ -0,0 +1,35 @@
+Ripped from Debian patchset 6
+
+--- src/include/game/game_data.h
++++ src/include/game/game_data.h
+@@ -71,7 +71,7 @@
+ typedef struct AI {
+ int active;
+ int tdiff;
+- long lasttime;
++ unsigned int lasttime;
+ segment2 left, right, front, backleft;
+ } AI;
+
+--- src/include/video/fonttex.h
++++ src/include/video/fonttex.h
+@@ -10,7 +10,7 @@
+ int lower; /* lowest ascii character (normally: 32) */
+ int upper; /* highest ascii character (normally: 126) */
+
+- int *texID;
++ unsigned int *texID;
+
+ char *fontname;
+ char *bitmapname;
+--- src/video/trail.c
++++ src/video/trail.c
+@@ -19,7 +19,7 @@
+ n[1] = s->vStart.v[1] - s->vDirection.v[0];
+ tmp[0] = eye[0] - s->vStart.v[0];
+ tmp[1] = eye[1] - s->vStart.v[1];
+- if(n[0] == n[1] == 0) return length(tmp);
++ if(n[0] == 0 && n[1] == 0) return length(tmp);
+ return abs(scalarprod2(n, tmp) / length(n));
+ }
+
diff --git a/games-action/gltron/gltron-0.70.ebuild b/games-action/gltron/gltron-0.70-r1.ebuild
index c8ddae925921..033ddc4ddb66 100644
--- a/games-action/gltron/gltron-0.70.ebuild
+++ b/games-action/gltron/gltron-0.70-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/gltron-0.70.ebuild,v 1.6 2005/07/30 04:37:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/gltron-0.70-r1.ebuild,v 1.1 2005/07/30 04:53:52 vapier Exp $
inherit eutils games
@@ -26,6 +26,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${P}-configure.patch
epatch "${FILESDIR}"/${P}-prototypes.patch
+ epatch "${FILESDIR}"/${P}-debian.patch
}
src_compile() {