summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/holotz-castle/files')
-rw-r--r--games-arcade/holotz-castle/files/digest-holotz-castle-1.3.61
-rw-r--r--games-arcade/holotz-castle/files/holotz-castle-1.3.6-build.patch39
2 files changed, 40 insertions, 0 deletions
diff --git a/games-arcade/holotz-castle/files/digest-holotz-castle-1.3.6 b/games-arcade/holotz-castle/files/digest-holotz-castle-1.3.6
new file mode 100644
index 000000000000..134b0e1add56
--- /dev/null
+++ b/games-arcade/holotz-castle/files/digest-holotz-castle-1.3.6
@@ -0,0 +1 @@
+MD5 61b97f12f5ca5d67c4db7418b2f6f166 holotz-castle-1.3.6-src.tar.gz 3581401
diff --git a/games-arcade/holotz-castle/files/holotz-castle-1.3.6-build.patch b/games-arcade/holotz-castle/files/holotz-castle-1.3.6-build.patch
new file mode 100644
index 000000000000..7618f4ddfba7
--- /dev/null
+++ b/games-arcade/holotz-castle/files/holotz-castle-1.3.6-build.patch
@@ -0,0 +1,39 @@
+--- JLib/Makefile
++++ JLib/Makefile
+@@ -17,4 +17,4 @@
+ # Definir -D_JLIB_DEBUG para hacer debug de JLib. Compilar el programa a debugear también con este flag
+-CFLAGS=-I. -O3 -ffast-math $(CPU_OPTS) -fPIC
+-LDFLAGS=-L. -ffast-math -lSDL -lSDL_image -lSDL_ttf -lSDL_mixer
++CXXFLAGS=-I. $(CPU_OPTS)
++LDFLAGS=-L. -lSDL -lSDL_image -lSDL_ttf -lSDL_mixer
+
+@@ -24,11 +24,10 @@
+ libJLib: $(JLIB_OBJS)
+- g++ -shared -o $@.so $? \
+- && ar rvus $@.a $? \
++ ar rvus $@.a $?
+
+ $(GRAPHICS)/%.o: $(GRAPHICS)/%.cpp
+- g++ $(CFLAGS) -c -o $@ $<
++ $(CXX) $(CXXFLAGS) -c -o $@ $<
+ $(UTIL)/%.o: $(UTIL)/%.cpp
+- g++ $(CFLAGS) -c -o $@ $<
++ $(CXX) $(CXXFLAGS) -c -o $@ $<
+ $(MATH)/%.o: $(MATH)/%.cpp
+- g++ $(CFLAGS) -c -o $@ $<
++ $(CXX) $(CXXFLAGS) -c -o $@ $<
+
+--- src/Makefile
++++ src/Makefile
+@@ -27,3 +27,3 @@
+
+-all: JLib HC HCed
++all: HC HCed
+
+@@ -39,4 +39,4 @@
+ # Define -D_JLIB_DEBUG for JLib debug mode. Put it also in JLib's Makefile.
+-CFLAGS=-O3 -Wshadow $(CPU_OPTS) -ffast-math -c -I. -I../JLib $(shell sdl-config --cflags)
+-LDFLAGS=-L/usr/X11R6/lib -ffast-math -lSDL -lSDL_image -lSDL_mixer -lSDL_ttf -lGL -lGLU
++CFLAGS=-Wshadow $(CPU_OPTS) -c -I. -I../JLib $(shell sdl-config --cflags)
++LDFLAGS=-lSDL -lSDL_image -lSDL_mixer -lSDL_ttf -lGL -lGLU
+