summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/gemhun')
-rw-r--r--games-puzzle/gemhun/ChangeLog6
-rw-r--r--games-puzzle/gemhun/files/gemhun-20040529-srand.patch11
-rw-r--r--games-puzzle/gemhun/gemhun-20040529.ebuild22
3 files changed, 31 insertions, 8 deletions
diff --git a/games-puzzle/gemhun/ChangeLog b/games-puzzle/gemhun/ChangeLog
index a1b401829fbd..9d537716d3c9 100644
--- a/games-puzzle/gemhun/ChangeLog
+++ b/games-puzzle/gemhun/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/gemhun
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gemhun/ChangeLog,v 1.7 2006/03/23 19:47:43 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gemhun/ChangeLog,v 1.8 2006/10/26 22:50:03 nyhm Exp $
+
+ 26 Oct 2006; Tristan Heaven <nyhm@gentoo.org>
+ +files/gemhun-20040529-srand.patch, gemhun-20040529.ebuild:
+ Fix autotools stuff and an arithmetic exception, bug #125374
23 Mar 2006; Michael Hanselmann <hansmi@gentoo.org>
gemhun-20040529.ebuild:
diff --git a/games-puzzle/gemhun/files/gemhun-20040529-srand.patch b/games-puzzle/gemhun/files/gemhun-20040529-srand.patch
new file mode 100644
index 000000000000..b8b3d40952f7
--- /dev/null
+++ b/games-puzzle/gemhun/files/gemhun-20040529-srand.patch
@@ -0,0 +1,11 @@
+--- src/network.cpp
++++ src/network.cpp
+@@ -68,7 +68,7 @@
+ sprintf ( self . alias, "%s", "you" ) ;
+
+ srand ( SDL_GetTicks () + self . ip . port + (int) self . alias +
+- rand () - SDL_GetTicks () + rand () % SDL_GetTicks () ) ;
++ rand () - SDL_GetTicks () + rand () ) ;
+
+ sprintf ( self . key, "%s", CreateKey () . c_str () ) ;
+
diff --git a/games-puzzle/gemhun/gemhun-20040529.ebuild b/games-puzzle/gemhun/gemhun-20040529.ebuild
index c262fb5d2eb7..c0a35e2cd211 100644
--- a/games-puzzle/gemhun/gemhun-20040529.ebuild
+++ b/games-puzzle/gemhun/gemhun-20040529.ebuild
@@ -1,7 +1,9 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gemhun/gemhun-20040529.ebuild,v 1.3 2006/03/23 19:47:43 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gemhun/gemhun-20040529.ebuild,v 1.4 2006/10/26 22:50:03 nyhm Exp $
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=latest
inherit eutils autotools games
DESCRIPTION="A puzzle game about grouping gems of a chosen amount together"
@@ -16,9 +18,8 @@ KEYWORDS="ppc x86"
IUSE=""
DEPEND="dev-games/kyra
- >=media-libs/sdl-mixer-1.2.1
+ media-libs/sdl-mixer
virtual/opengl
- sys-libs/ncurses
media-libs/sdl-net
media-libs/libpng"
@@ -30,13 +31,20 @@ src_unpack() {
# Fix to comply with gentoo-path
# and to remove a nasty violation by commenting a network calls
# Until upstream fix, that is
- epatch "${FILESDIR}/${PV}-gentoo.patch"
- eautoreconf || die "eautoreconf failed"
+ epatch \
+ "${FILESDIR}/${PV}-gentoo.patch" \
+ "${FILESDIR}"/${P}-srand.patch
+ AT_M4DIR=m4 eautoreconf
+}
+
+src_compile() {
+ egamesconf --disable-nls || die
+ emake || die "emake failed"
}
src_install() {
- make DESTDIR="${D}" install || die "Install failed"
- dodoc AUTHORS ChangeLog README README.Install TODO
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README TODO
insinto "${GAMES_DATADIR}/GemHunters/pax/"
doins -r ../fairylands ../stars_in_the_night || die "doins failed"
doicon pixmaps/${PN}.png