summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kalgebra/kalgebra-4.11.5.ebuild')
-rw-r--r--kde-base/kalgebra/kalgebra-4.11.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/kde-base/kalgebra/kalgebra-4.11.5.ebuild b/kde-base/kalgebra/kalgebra-4.11.5.ebuild
new file mode 100644
index 000000000000..1778380b378f
--- /dev/null
+++ b/kde-base/kalgebra/kalgebra-4.11.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/kalgebra-4.11.5.ebuild,v 1.1 2014/01/10 04:21:37 creffett Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+DECLARATIVE_REQUIRED="always"
+OPENGL_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="MathML-based graph calculator for KDE."
+HOMEPAGE="http://www.kde.org/applications/education/kalgebra
+http://edu.kde.org/kalgebra"
+KEYWORDS=" ~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep analitza opengl?)
+ $(add_kdebase_dep libkdeedu)
+ opengl? ( virtual/glu )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with opengl OpenGL)
+ )
+
+ kde4-base_src_configure
+}