summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/knode/knode-3.5.10.ebuild')
-rw-r--r--kde-base/knode/knode-3.5.10.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-base/knode/knode-3.5.10.ebuild b/kde-base/knode/knode-3.5.10.ebuild
new file mode 100644
index 000000000000..12fb37e6a085
--- /dev/null
+++ b/kde-base/knode/knode-3.5.10.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/knode/knode-3.5.10.ebuild,v 1.1 2008/09/13 23:59:09 carlo Exp $
+
+KMNAME=kdepim
+EAPI="1"
+inherit kde-meta eutils
+
+DESCRIPTION="A newsreader for KDE"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=kde-base/libkdepim-${PV}:${SLOT}
+>=kde-base/libkdenetwork-${PV}:${SLOT}
+>=kde-base/kontact-${PV}:${SLOT}
+>=kde-base/libkmime-${PV}:${SLOT}
+>=kde-base/libkpgp-${PV}:${SLOT}"
+
+RDEPEND="${DEPEND}"
+
+KMCOPYLIB="
+ libkdepim libkdepim
+ libkpinterfaces kontact/interfaces
+ libkmime libkmime
+ libkpgp libkpgp"
+KMEXTRACTONLY="
+ libkdepim/
+ libkdenetwork/
+ kontact/interfaces
+ libkmime
+ libkpgp
+ libemailfunctions"
+KMEXTRA="kontact/plugins/knode" # We add here the kontact's plugin instead of compiling it with kontact because it needs a lot of this programs deps.