summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/feh')
-rw-r--r--media-gfx/feh/feh-1.1.0.ebuild34
-rw-r--r--media-gfx/feh/files/digest-feh-1.1.01
2 files changed, 35 insertions, 0 deletions
diff --git a/media-gfx/feh/feh-1.1.0.ebuild b/media-gfx/feh/feh-1.1.0.ebuild
new file mode 100644
index 000000000000..12c031d686fc
--- /dev/null
+++ b/media-gfx/feh/feh-1.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Craig Joly <joly@ee.ualberta.ca>
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A fast, lightweight imageviewer using imlib2"
+SRC_URI="http://www.linuxbrit.co.uk/downloads/feh-${PV}.tar.gz"
+HOMEPAGE="http://www.linuxbrit.co.uk/feh"
+
+DEPEND="media-libs/imlib2"
+
+
+src_compile() {
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host=${CHOST} || die
+
+ emake || die
+}
+
+src_install () {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ docsdir=${D}/usr/share/doc/${PF} \
+ install || die
+
+ # gzip the docs
+ gzip ${D}/usr/share/doc/${PF}/*
+}
+
diff --git a/media-gfx/feh/files/digest-feh-1.1.0 b/media-gfx/feh/files/digest-feh-1.1.0
new file mode 100644
index 000000000000..6c5657140651
--- /dev/null
+++ b/media-gfx/feh/files/digest-feh-1.1.0
@@ -0,0 +1 @@
+MD5 ba39dde9998996b9728c074869ba75db feh-1.1.0.tar.gz 471040