summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/pixie/files')
-rw-r--r--media-gfx/pixie/files/digest-pixie-1.3.111
-rw-r--r--media-gfx/pixie/files/digest-pixie-1.3.201
-rw-r--r--media-gfx/pixie/files/digest-pixie-1.3.5-r11
-rw-r--r--media-gfx/pixie/files/pixie-1.3.11-Makefile.patch14
-rw-r--r--media-gfx/pixie/files/pixie-1.3.11-gcc3.4.patch169
-rw-r--r--media-gfx/pixie/files/pixie-1.3.11-pic.patch12
-rw-r--r--media-gfx/pixie/files/pixie-1.3.5-Makefile.patch26
-rw-r--r--media-gfx/pixie/files/pixie-1.3.5-math.patch47
8 files changed, 1 insertions, 270 deletions
diff --git a/media-gfx/pixie/files/digest-pixie-1.3.11 b/media-gfx/pixie/files/digest-pixie-1.3.11
deleted file mode 100644
index 5e0cb445616e..000000000000
--- a/media-gfx/pixie/files/digest-pixie-1.3.11
+++ /dev/null
@@ -1 +0,0 @@
-MD5 4c0935f1f0fefeaaa303d6e1a5c1f7ac Pixie-src-1.3.11.tgz 4925938
diff --git a/media-gfx/pixie/files/digest-pixie-1.3.20 b/media-gfx/pixie/files/digest-pixie-1.3.20
new file mode 100644
index 000000000000..b418897e5de9
--- /dev/null
+++ b/media-gfx/pixie/files/digest-pixie-1.3.20
@@ -0,0 +1 @@
+MD5 3fef0588af57af5ea2521a0805a30c92 Pixie-src-1.3.20.tgz 4924993
diff --git a/media-gfx/pixie/files/digest-pixie-1.3.5-r1 b/media-gfx/pixie/files/digest-pixie-1.3.5-r1
deleted file mode 100644
index fbafc3db7e82..000000000000
--- a/media-gfx/pixie/files/digest-pixie-1.3.5-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 244a168fe7942d449566c8ad15e6caf9 Pixie-src-1.3.5.tgz 4269413
diff --git a/media-gfx/pixie/files/pixie-1.3.11-Makefile.patch b/media-gfx/pixie/files/pixie-1.3.11-Makefile.patch
deleted file mode 100644
index 6c69c3940829..000000000000
--- a/media-gfx/pixie/files/pixie-1.3.11-Makefile.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -Naur Pixie.orig/Makefile.am Pixie.Makefile/Makefile.am
---- Pixie.orig/Makefile.am 2004-06-13 20:00:09.000000000 -0700
-+++ Pixie.Makefile/Makefile.am 2004-06-14 18:33:41.169944272 -0700
-@@ -11,8 +11,8 @@
- cp -rf $(srcdir)/shaders $(distdir)
-
- install-data-local:
-- cp -rf $(srcdir)/doc $(prefix)
-- cp -rf $(srcdir)/shaders $(prefix)
-+ cp -rf $(srcdir)/doc $(DESTDIR)$(prefix)
-+ cp -rf $(srcdir)/shaders $(DESTDIR)$(prefix)
-
-
-
diff --git a/media-gfx/pixie/files/pixie-1.3.11-gcc3.4.patch b/media-gfx/pixie/files/pixie-1.3.11-gcc3.4.patch
deleted file mode 100644
index cd28046d2b0d..000000000000
--- a/media-gfx/pixie/files/pixie-1.3.11-gcc3.4.patch
+++ /dev/null
@@ -1,169 +0,0 @@
-diff -Naur Pixie.orig/src/common/containers.h Pixie.gcc34/src/common/containers.h
---- Pixie.orig/src/common/containers.h 2004-06-13 20:00:09.000000000 -0700
-+++ Pixie.gcc34/src/common/containers.h 2004-06-14 19:02:34.133763870 -0700
-@@ -53,13 +53,13 @@
- virtual ~CDictionary() { }
-
- // inserts an entity into the dictionary
-- virtual void insert(keyType,valType) = NULL;
-+ virtual void insert(keyType,valType) = 0;
- // return 1 if the entity is found in the dictionary
-- virtual int find(keyType,valType &) const = NULL;
-+ virtual int find(keyType,valType &) const = 0;
- // return 1 if the entity is found in the dictionary and erase it
-- virtual int erase(keyType,valType &) = NULL;
-+ virtual int erase(keyType,valType &) = 0;
- // Delete the dictionary including everything in it
-- virtual void destroy() = NULL;
-+ virtual void destroy() = 0;
- };
-
- ///////////////////////////////////////////////////////////////////////
-diff -Naur Pixie.orig/src/framebuffer/framebuffer.h Pixie.gcc34/src/framebuffer/framebuffer.h
---- Pixie.orig/src/framebuffer/framebuffer.h 2004-06-13 20:00:09.000000000 -0700
-+++ Pixie.gcc34/src/framebuffer/framebuffer.h 2004-06-14 19:01:19.992178690 -0700
-@@ -50,8 +50,8 @@
- char *name; // Name of the display
- char *samples; // Samples for the display
-
-- virtual int data(int,int,int,int,float *) = NULL; // Store data
-- virtual void finish() = NULL; // Finish displaying the data
-+ virtual int data(int,int,int,int,float *) = 0; // Store data
-+ virtual void finish() = 0; // Finish displaying the data
-
- void clampData(int,int,float *); // Clamp the data so that everything is between 0 and 1
- };
-diff -Naur Pixie.orig/src/ri/cache.h Pixie.gcc34/src/ri/cache.h
---- Pixie.orig/src/ri/cache.h 2004-06-13 20:00:06.000000000 -0700
-+++ Pixie.gcc34/src/ri/cache.h 2004-06-14 19:02:59.297550257 -0700
-@@ -52,8 +52,8 @@
- CCache(const char *,unsigned int);
- ~CCache();
-
-- virtual void lookup(float *,const float *,const float *,const CGlobalIllumLookup *) = NULL;
-- virtual void cachesample(float *,const float *,const float *,float) = NULL;
-+ virtual void lookup(float *,const float *,const float *,const CGlobalIllumLookup *) = 0;
-+ virtual void cachesample(float *,const float *,const float *,float) = 0;
- virtual void finalize(const CGlobalIllumLookup *) { }
-
- protected:
-diff -Naur Pixie.orig/src/ri/hierarchy.h Pixie.gcc34/src/ri/hierarchy.h
---- Pixie.orig/src/ri/hierarchy.h 2004-06-13 20:00:06.000000000 -0700
-+++ Pixie.gcc34/src/ri/hierarchy.h 2004-06-14 19:04:02.661940051 -0700
-@@ -49,9 +49,9 @@
- // Date last edited : 3/18/2002
- class CTracable {
- public:
-- virtual void bound(float *,float *) const = NULL;
-- virtual void intersect(CRay *) = NULL;
-- virtual int intersect(const float *,const float *) const = NULL;
-+ virtual void bound(float *,float *) const = 0;
-+ virtual void intersect(CRay *) = 0;
-+ virtual int intersect(const float *,const float *) const = 0;
-
- int ID;
- };
-diff -Naur Pixie.orig/src/ri/reyes.h Pixie.gcc34/src/ri/reyes.h
---- Pixie.orig/src/ri/reyes.h 2004-06-13 20:00:07.000000000 -0700
-+++ Pixie.gcc34/src/ri/reyes.h 2004-06-14 19:03:21.869770596 -0700
-@@ -123,10 +123,10 @@
- void renderFrame(); // Right after world end to force rendering of the entire frame
-
- // The following functions must be overriden by the child rasterizer
-- virtual void rasterBegin(int,int,int,int) = NULL;
-- virtual void rasterDrawPrimitives(TRasterPrimitive *,int)= NULL;
-- virtual int rasterProbeTri(TRasterPrimitive *) = NULL;
-- virtual void rasterEnd(float *) = NULL;
-+ virtual void rasterBegin(int,int,int,int) = 0;
-+ virtual void rasterDrawPrimitives(TRasterPrimitive *,int)= 0;
-+ virtual int rasterProbeTri(TRasterPrimitive *) = 0;
-+ virtual void rasterEnd(float *) = 0;
-
-
- void drawObject(CObject *,const float *,const float *); // Draw an object
-diff -Naur Pixie.orig/src/ri/shader.h Pixie.gcc34/src/ri/shader.h
---- Pixie.orig/src/ri/shader.h 2004-06-13 20:00:07.000000000 -0700
-+++ Pixie.gcc34/src/ri/shader.h 2004-06-14 19:03:45.208862524 -0700
-@@ -211,7 +211,7 @@
- // Date last edited : 3/23/2003
- class CGatherVariable {
- public:
-- virtual void record(int,CGatherRay **,float **varying) = NULL;
-+ virtual void record(int,CGatherRay **,float **varying) = 0;
-
- CGatherVariable *next; // The next item in the linked list
- int shade; // TRUE if this variable requires shading
-@@ -395,12 +395,12 @@
- void detach() { refCount--; if (refCount == 0) delete this; }
- void check() { if (refCount == 0) delete this; }
-
-- virtual void illuminate(CShadingContext *) = NULL;
-- virtual void setParameters(int,char **,void **) = NULL;
-- virtual int getParameter(const char *,void *) = NULL;
-- virtual void execute(CShadingContext *) = NULL;
-- virtual unsigned int requiredParameters() = NULL;
-- virtual const char *getName() = NULL;
-+ virtual void illuminate(CShadingContext *) = 0;
-+ virtual void setParameters(int,char **,void **) = 0;
-+ virtual int getParameter(const char *,void *) = 0;
-+ virtual void execute(CShadingContext *) = 0;
-+ virtual unsigned int requiredParameters() = 0;
-+ virtual const char *getName() = 0;
-
- int refCount; // The refcount to manage the clones
- CXform *xform;
-diff -Naur Pixie.orig/src/ri/shading.h Pixie.gcc34/src/ri/shading.h
---- Pixie.orig/src/ri/shading.h 2004-06-13 20:00:07.000000000 -0700
-+++ Pixie.gcc34/src/ri/shading.h 2004-06-14 19:04:38.863878128 -0700
-@@ -176,10 +176,10 @@
- int depth; // The transparency depth of the bundle
- CShaderInstance *postShader; // The shader to execute after the raytrace
-
-- virtual int postTraceAction() = NULL; // The function to be called after the rays are traced
-- virtual void postShade(int,CRay **,float **) = NULL; // The function that's called with the shade results
-- virtual void postShade(int,CRay **) = NULL; // The function that's called with the rays that don't intersect anything
-- virtual void post() = NULL; // The function that's called after each pass
-+ virtual int postTraceAction() = 0; // The function to be called after the rays are traced
-+ virtual void postShade(int,CRay **,float **) = 0; // The function that's called with the shade results
-+ virtual void postShade(int,CRay **) = 0; // The function that's called with the rays that don't intersect anything
-+ virtual void post() = 0; // The function that's called after each pass
- };
-
-
-@@ -201,17 +201,17 @@
- void beginWorld(); // We're starting to specify geometry
- void endWorld(); // We're done specifying geometry
-
-- virtual void renderFrame() = NULL; // Right after world end to force rendering of the entire frame
-+ virtual void renderFrame() = 0; // Right after world end to force rendering of the entire frame
-
- // Delayed rendering functions
-- virtual void drawObject(CObject *,const float *,const float *) = NULL;
-- virtual void drawTriangle(CObject *,const float *,const float *,const float *) = NULL;
-- virtual void drawQuad(CObject *,const float *,const float *,const float *,const float *) = NULL;
-+ virtual void drawObject(CObject *,const float *,const float *) = 0;
-+ virtual void drawTriangle(CObject *,const float *,const float *,const float *) = 0;
-+ virtual void drawQuad(CObject *,const float *,const float *,const float *,const float *) = 0;
-
- // Primitive creation functions
-- virtual void drawGrid(CSurface *,int,int,float,float,float,float) = NULL;
-- virtual void drawRibbon(CSurface *,int,float,float) = NULL;
-- virtual void drawPoints(CSurface *,int) = NULL;
-+ virtual void drawGrid(CSurface *,int,int,float,float,float,float) = 0;
-+ virtual void drawRibbon(CSurface *,int,float,float) = 0;
-+ virtual void drawPoints(CSurface *,int) = 0;
-
- // Some shading functions
- CShadingState *currentShadingState; // The current shading state
-diff -Naur Pixie.orig/src/ri/texture.h Pixie.gcc34/src/ri/texture.h
---- Pixie.orig/src/ri/texture.h 2004-06-13 20:00:08.000000000 -0700
-+++ Pixie.gcc34/src/ri/texture.h 2004-06-14 19:04:53.404443347 -0700
-@@ -83,7 +83,7 @@
- int fileWidth,fileHeight; // The physical size in the file
- protected:
- // This function must be overriden by the child class
-- virtual void lookupPixel(float *,int,int,const CTextureLookup *) = NULL; // Lookup 4 pixel values
-+ virtual void lookupPixel(float *,int,int,const CTextureLookup *) = 0; // Lookup 4 pixel values
- };
-
-
diff --git a/media-gfx/pixie/files/pixie-1.3.11-pic.patch b/media-gfx/pixie/files/pixie-1.3.11-pic.patch
deleted file mode 100644
index 81ec5fcc5bc3..000000000000
--- a/media-gfx/pixie/files/pixie-1.3.11-pic.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur Pixie.orig/src/common/Makefile.am Pixie.amd64/src/common/Makefile.am
---- Pixie.orig/src/common/Makefile.am 2004-06-13 20:00:09.000000000 -0700
-+++ Pixie.amd64/src/common/Makefile.am 2004-06-14 18:59:50.884099612 -0700
-@@ -1,6 +1,8 @@
- noinst_LIBRARIES = libcommon.a
-
- libcommon_a_SOURCES = algebra.cpp os.cpp memoryman.cpp
-+libcommon_a_CFLAGS = -fPIC -DPIC
-+libcommon_a_CXXFLAGS = -fPIC -DPIC
-
- EXTRA_DIST = *.h *.cpp *.dsp
-
diff --git a/media-gfx/pixie/files/pixie-1.3.5-Makefile.patch b/media-gfx/pixie/files/pixie-1.3.5-Makefile.patch
deleted file mode 100644
index 19446e92e3f9..000000000000
--- a/media-gfx/pixie/files/pixie-1.3.5-Makefile.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- Makefile.am.orig 2004-04-29 16:49:45.000000000 -0700
-+++ Makefile.am 2004-04-29 17:06:12.000000000 -0700
-@@ -1,9 +1,5 @@
- SUBDIRS = src
-
--topdir = $(prefix)
--
--top_DATA = README AUTHORS LICENSE COPYING
--
- EXTRA_DIST = Pixie.dsw Pixie.ncb Pixie.opt DEVNOTES LICENSE makeclean.bat makeinst.bat tutorials win32inst
-
- dist-hook:
-@@ -11,11 +7,6 @@
- cp -rf $(srcdir)/shaders $(distdir)
-
- install-data-local:
-- cp -rf $(srcdir)/doc $(prefix)
-- cp -rf $(srcdir)/shaders $(prefix)
--
--
--
--
--
-+ cp -rf $(srcdir)/doc $(DESTDIR)$(prefix)
-+ cp -rf $(srcdir)/shaders $(DESTDIR)$(prefix)
-
diff --git a/media-gfx/pixie/files/pixie-1.3.5-math.patch b/media-gfx/pixie/files/pixie-1.3.5-math.patch
deleted file mode 100644
index 18366104e2fc..000000000000
--- a/media-gfx/pixie/files/pixie-1.3.5-math.patch
+++ /dev/null
@@ -1,47 +0,0 @@
---- src/common/global.h.orig 2004-04-29 17:30:45.000000000 -0700
-+++ src/common/global.h 2004-04-29 17:33:40.000000000 -0700
-@@ -47,6 +47,8 @@
- #ifndef GLOBAL_H
- #define GLOBAL_H
-
-+#include <math.h>
-+
- // The Pixie version
- #define VERSION_RELEASE 1
- #define VERSION_BETA 3
-@@ -54,21 +56,33 @@
-
- // Come constant definitions
- // Math constants
-+#ifndef INFINITY
- #define INFINITY (float) 1e30
--#define EPSILON (float) 1e-6
-+#endif
-
-+#define EPSILON (float) 1e-6
-
- // The most famous number
- #ifndef PI
-+#ifdef M_PI
-+#define PI M_PI
-+#else
- #define PI (float) 3.141592653589793238462643383279502884197169399375105820974944592308
-+#endif
-+#endif
-+
-+#ifndef DOUBLE_PI
-+#ifdef M_PIl
-+#define DOUBLE_PI M_PIl
-+#else
- #define DOUBLE_PI 3.141592653589793238462643383279502884197169399375105820974944592308
- #endif
-+#endif
-
- // Logic constants
- #define TRUE 1
- #define FALSE 0
-
--
- // Misc Options and Attributes constants
- #ifdef min
- #undef min