summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/pixie/pixie-2.2.1.ebuild')
-rw-r--r--media-gfx/pixie/pixie-2.2.1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/media-gfx/pixie/pixie-2.2.1.ebuild b/media-gfx/pixie/pixie-2.2.1.ebuild
new file mode 100644
index 000000000000..f12f5b765891
--- /dev/null
+++ b/media-gfx/pixie/pixie-2.2.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pixie/pixie-2.2.1.ebuild,v 1.1 2007/07/11 06:31:12 eradicator Exp $
+
+inherit eutils multilib autotools
+
+IUSE="fltk openexr X"
+
+MY_PN="Pixie"
+S="${WORKDIR}/${MY_PN}"
+
+DESCRIPTION="RenderMan like photorealistic renderer."
+HOMEPAGE="http://pixie.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-src-${PV}.tgz"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="media-libs/jpeg
+ sys-libs/zlib
+ media-libs/tiff
+ openexr? ( media-libs/openexr )
+ fltk? ( x11-libs/fltk )
+ X? ( x11-libs/libXext )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ # Bugfixes already in cvs upstream
+ epatch ${FILESDIR}/${PN}-2.2.1-riby.patch
+
+ # Force make to rebuild the shaders since the packaged ones
+ # are not always compiled with the latest version of sdr
+ epatch ${FILESDIR}/${PN}-2.2.1-genshaders.patch
+ rm ${S}/shaders/*.sdr
+
+ eautoreconf
+}
+
+src_compile() {
+ ewarn "Compilation of pixie is memory intensive. If you experience problems, try"
+ ewarn "removing -pipe from your CFLAGS. Additionally, disabling optimizations (-O0)"
+ ewarn "will cause much less memory consumption. See bug #171367 for more info."
+
+ econf || die "econf failed"
+ emake -j1 || die "Make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ keepdir /usr/$(get_libdir)/Pixie/procedurals
+ keepdir /usr/share/Pixie/models
+
+ insinto /usr/share/Pixie/textures
+ doins ${S}/textures/checkers.tif
+
+ edos2unix ${D}/usr/share/Pixie/shaders/*
+ mv ${D}/usr/share/doc/Pixie ${D}/usr/share/doc/${PF}
+}