summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/jpeginfo/ChangeLog9
-rw-r--r--media-gfx/jpeginfo/jpeginfo-1.6.1.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/media-gfx/jpeginfo/ChangeLog b/media-gfx/jpeginfo/ChangeLog
index fa73d7913ea4..88352540dd16 100644
--- a/media-gfx/jpeginfo/ChangeLog
+++ b/media-gfx/jpeginfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/jpeginfo
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/jpeginfo/ChangeLog,v 1.20 2010/12/28 23:42:21 xmw Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/jpeginfo/ChangeLog,v 1.21 2011/04/27 18:22:03 ssuominen Exp $
+
+*jpeginfo-1.6.1 (27 Apr 2011)
+
+ 27 Apr 2011; Samuli Suominen <ssuominen@gentoo.org> +jpeginfo-1.6.1.ebuild:
+ Version bump.
28 Dec 2010; Michael Weber <xmw@gentoo.org> jpeginfo-1.6.0.ebuild:
Change media-libs/jpeg to virtual/jpeg (thanks to Holger Hoffstätte
diff --git a/media-gfx/jpeginfo/jpeginfo-1.6.1.ebuild b/media-gfx/jpeginfo/jpeginfo-1.6.1.ebuild
new file mode 100644
index 000000000000..ddeb0b54bc76
--- /dev/null
+++ b/media-gfx/jpeginfo/jpeginfo-1.6.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/jpeginfo/jpeginfo-1.6.1.ebuild,v 1.1 2011/04/27 18:22:03 ssuominen Exp $
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Prints information and tests integrity of JPEG/JFIF files."
+HOMEPAGE="http://www.kokkonen.net/tjko/projects.html"
+SRC_URI="http://www.kokkonen.net/tjko/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND="virtual/jpeg"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.6.0-parallel_install.patch
+}
+
+src_configure() {
+ tc-export CC
+ econf
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die
+ dodoc README
+}