summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/exaile/files')
-rw-r--r--media-sound/exaile/files/digest-exaile-0.2.9-r1 (renamed from media-sound/exaile/files/digest-exaile-0.2.9)0
-rw-r--r--media-sound/exaile/files/digest-exaile-0.2.9_beta1-r13
-rw-r--r--media-sound/exaile/files/exaile-0.2.9_beta1-unicode.patch77
-rw-r--r--media-sound/exaile/files/exaile-0.2.x-strip.patch11
4 files changed, 11 insertions, 80 deletions
diff --git a/media-sound/exaile/files/digest-exaile-0.2.9 b/media-sound/exaile/files/digest-exaile-0.2.9-r1
index 7fa98eb6bbe1..7fa98eb6bbe1 100644
--- a/media-sound/exaile/files/digest-exaile-0.2.9
+++ b/media-sound/exaile/files/digest-exaile-0.2.9-r1
diff --git a/media-sound/exaile/files/digest-exaile-0.2.9_beta1-r1 b/media-sound/exaile/files/digest-exaile-0.2.9_beta1-r1
deleted file mode 100644
index 2bae28bad51b..000000000000
--- a/media-sound/exaile/files/digest-exaile-0.2.9_beta1-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 145418e89b621df838b9936effcda703 exaile_0.2.9b.tar.gz 789660
-RMD160 e26d4fbb6c265026d71c80d6754deacbed57da01 exaile_0.2.9b.tar.gz 789660
-SHA256 e21eb72f5048755137117c1e720bee8a3eaf7aaf707c90e5e8308ee56f2e8059 exaile_0.2.9b.tar.gz 789660
diff --git a/media-sound/exaile/files/exaile-0.2.9_beta1-unicode.patch b/media-sound/exaile/files/exaile-0.2.9_beta1-unicode.patch
deleted file mode 100644
index 89acf190b923..000000000000
--- a/media-sound/exaile/files/exaile-0.2.9_beta1-unicode.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-Index: xl/media/__init__.py
-===================================================================
---- xl/media/__init__.py (revision 2146)
-+++ xl/media/__init__.py (working copy)
-@@ -117,7 +117,7 @@
-
- # This would be more nicely written using conditional expressions
- # but that is Python 2.5 only
-- if type(title) is unicode:
-+ if type(title) is unicode:
- self._title = title
- else:
- self._title = unicode(title, encoding)
-Index: xl/player.py
-===================================================================
---- xl/player.py (revision 2146)
-+++ xl/player.py (working copy)
-@@ -302,11 +302,11 @@
- self.on_sync_message))
-
- if '://' not in uri:
-- if not os.path.isfile(uri):
-+ if not os.path.isfile(uri.encode('latin1')):
- raise Exception('Specified file does not exist')
-
- uri = 'file://%s' % uri
-- self.playbin.set_property('uri', uri)
-+ self.playbin.set_property('uri', uri.encode('latin1'))
-
- self.playbin.set_state(gst.STATE_PLAYING)
-
-Index: xl/panels.py
-===================================================================
---- xl/panels.py (revision 2146)
-+++ xl/panels.py (working copy)
-@@ -378,8 +378,8 @@
- loc = ["device_%s://%s" % (driver_name,
- urllib.quote(l.loc)) for l in loc]
- else:
-- loc = [urllib.quote(str(l.loc)) for l in loc]
--
-+ loc = [urllib.quote(l.loc.encode('latin1')) for l in loc]
-+
- selection.set_uris(loc)
-
- def append_recursive(self, iter, add):
-@@ -2721,7 +2721,7 @@
- """
-
- songs = self.get_selected_songs()
-- uris = [song.loc for song in songs]
-+ uris = [urllib.quote(song.loc.encode('latin1')) for song in songs]
-
- sel.set_uris(uris)
-
-Index: xl/trackslist.py
-===================================================================
---- xl/trackslist.py (revision 2146)
-+++ xl/trackslist.py (working copy)
-@@ -153,7 +153,7 @@
- # first, check to see if they dropped a folder
- copy = loc[:]
- for l in copy:
-- l = urllib.unquote(l)
-+ l = urllib.unquote_plus(l)
- if os.path.isdir(l.replace("file://", "")):
- # in this case, it is a folder
- for root, dirs, files in os.walk(l.replace("file://", '')):
-@@ -174,7 +174,7 @@
-
- for l in loc:
- l = l.replace("file://", "")
-- l = urllib.unquote(l)
-+ l = urllib.unquote_plus(l)
- m = re.search(r'^device_(\w+)://', l)
- if m:
- song = self.exaile.device_panel.get_song(l)
diff --git a/media-sound/exaile/files/exaile-0.2.x-strip.patch b/media-sound/exaile/files/exaile-0.2.x-strip.patch
new file mode 100644
index 000000000000..677da34cf2ad
--- /dev/null
+++ b/media-sound/exaile/files/exaile-0.2.x-strip.patch
@@ -0,0 +1,11 @@
+diff -ur exaile_0.2.8.orig/mmkeys/Makefile exaile_0.2.8/mmkeys/Makefile
+--- exaile_0.2.8.orig/mmkeys/Makefile 2006-11-01 02:11:34.000000000 +0200
++++ exaile_0.2.8/mmkeys/Makefile 2007-02-04 13:40:43.000000000 +0200
+@@ -7,7 +7,6 @@
+
+ mmkeys.so: mmkeyspy.o mmkeys.o mmkeysmodule.o
+ $(CC) $(LDFLAGS) -shared $^ -o $@
+- strip mmkeys.so
+
+ DEFS=`pkg-config --variable=defsdir pygtk-2.0`
+