summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/metasploit/ChangeLog5
-rw-r--r--net-analyzer/metasploit/metasploit-9999.ebuild12
2 files changed, 10 insertions, 7 deletions
diff --git a/net-analyzer/metasploit/ChangeLog b/net-analyzer/metasploit/ChangeLog
index 8e73048a5a10..ffde71c408ef 100644
--- a/net-analyzer/metasploit/ChangeLog
+++ b/net-analyzer/metasploit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/metasploit
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/ChangeLog,v 1.95 2014/06/07 21:32:00 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/ChangeLog,v 1.96 2014/06/28 00:49:34 zerochaos Exp $
+
+ 28 Jun 2014; Rick Farina <zerochaos@gentoo.org> metasploit-9999.ebuild:
+ fix msfupdate
*metasploit-4.9.3 (07 Jun 2014)
diff --git a/net-analyzer/metasploit/metasploit-9999.ebuild b/net-analyzer/metasploit/metasploit-9999.ebuild
index 2afca19d69fa..9101d236e402 100644
--- a/net-analyzer/metasploit/metasploit-9999.ebuild
+++ b/net-analyzer/metasploit/metasploit-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/metasploit-9999.ebuild,v 1.25 2014/05/30 14:18:39 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/metasploit-9999.ebuild,v 1.26 2014/06/28 00:49:34 zerochaos Exp $
EAPI="5"
@@ -191,8 +191,8 @@ all_ruby_prepare() {
}
each_ruby_prepare() {
- ${RUBY} -S bundle install --local || die
- ${RUBY} -S bundle check || die
+ BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle install --local || die
+ BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle check || die
#force all metasploit executables to ruby19, ruby18 is not supported anymore and ruby20 is not supported yet
#https://dev.metasploit.com/redmine/issues/8357
@@ -212,10 +212,10 @@ each_ruby_test() {
rm spec/tools/virustotal_spec.rb || die
# https://dev.metasploit.com/redmine/issues/8425
- ${RUBY} -S bundle exec rake db:create || die
- ${RUBY} -S bundle exec rake db:migrate || die
+ BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle exec rake db:create || die
+ BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle exec rake db:migrate || die
- MSF_DATABASE_CONFIG=config/database.yml ${RUBY} -S bundle exec rake || die
+ MSF_DATABASE_CONFIG=config/database.yml BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle exec rake || die
su postgres -c "dropuser msf_test_user" || die "failed to cleanup msf_test-user"
}