summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/pptpclient/ChangeLog9
-rw-r--r--net-dialup/pptpclient/pptpclient-1.7.2-r3.ebuild53
2 files changed, 61 insertions, 1 deletions
diff --git a/net-dialup/pptpclient/ChangeLog b/net-dialup/pptpclient/ChangeLog
index ea70c8ebfc43..ddd6d9e9a437 100644
--- a/net-dialup/pptpclient/ChangeLog
+++ b/net-dialup/pptpclient/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dialup/pptpclient
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/pptpclient/ChangeLog,v 1.58 2013/04/01 17:37:54 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/pptpclient/ChangeLog,v 1.59 2013/05/15 09:35:52 pinkbyte Exp $
+
+*pptpclient-1.7.2-r3 (15 May 2013)
+
+ 15 May 2013; Sergey Popov <pinkbyte@gentoo.org> +pptpclient-1.7.2-r3.ebuild:
+ Revision bump: bump EAPI to 5, add epatch_user, do not apply ip-path.patch
+ anymore, wrt bug #455470. Thanks to Michelangelo Scopelliti for discovering
+ this issue
01 Apr 2013; Sergey Popov <pinkbyte@gentoo.org> -pptpclient-1.7.1-r1.ebuild,
-files/pptpclient-1.7.1-process-name.patch:
diff --git a/net-dialup/pptpclient/pptpclient-1.7.2-r3.ebuild b/net-dialup/pptpclient/pptpclient-1.7.2-r3.ebuild
new file mode 100644
index 000000000000..533037d30859
--- /dev/null
+++ b/net-dialup/pptpclient/pptpclient-1.7.2-r3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/pptpclient/pptpclient-1.7.2-r3.ebuild,v 1.1 2013/05/15 09:35:52 pinkbyte Exp $
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+MY_P="${P/client}"
+MY_CMD="pptp-command-20130515"
+
+DESCRIPTION="Linux client for PPTP"
+HOMEPAGE="http://pptpclient.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pptpclient/${MY_P}.tar.gz
+ http://dev.gentoo.org/~pinkbyte/distfiles/pptpclient/${MY_CMD}.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="tk"
+
+DEPEND="net-dialup/ppp
+ dev-lang/perl
+ tk? ( dev-perl/perl-tk )"
+RDEPEND="${DEPEND}
+ sys-apps/iproute2"
+
+RESTRICT="test" #make test is useless and vector_test.c is broken
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( AUTHORS ChangeLog DEVELOPERS NEWS README TODO USING )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-process-name.patch
+ epatch_user
+}
+
+src_compile() {
+ emake OPTIMISE= DEBUG= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ default
+ dodoc Documentation/*
+ dodir /etc/pptp.d
+
+ # The current version of pptp-linux doesn't include the
+ # RH-specific portions, so include them ourselves.
+ newsbin "${WORKDIR}/${MY_CMD}" pptp-command
+ dosbin "${FILESDIR}/pptp_fe.pl"
+ use tk && dosbin "${FILESDIR}/xpptp_fe.pl"
+}