summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/mcabber/ChangeLog8
-rw-r--r--net-im/mcabber/files/digest-mcabber-0.9.53
-rw-r--r--net-im/mcabber/mcabber-0.9.4.ebuild20
-rw-r--r--net-im/mcabber/mcabber-0.9.5.ebuild91
4 files changed, 113 insertions, 9 deletions
diff --git a/net-im/mcabber/ChangeLog b/net-im/mcabber/ChangeLog
index abacc46b461c..eec1a17bbb09 100644
--- a/net-im/mcabber/ChangeLog
+++ b/net-im/mcabber/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/mcabber
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/ChangeLog,v 1.18 2007/11/19 23:07:59 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/ChangeLog,v 1.19 2007/11/20 00:41:02 wschlich Exp $
+
+*mcabber-0.9.5 (19 Nov 2007)
+
+ 19 Nov 2007; Wolfram Schlich <wschlich@gentoo.org> mcabber-0.9.4.ebuild,
+ +mcabber-0.9.5.ebuild:
+ version bump, add missing otr USE flag for 0.9.4 and new 0.9.5
*mcabber-0.9.4 (19 Nov 2007)
diff --git a/net-im/mcabber/files/digest-mcabber-0.9.5 b/net-im/mcabber/files/digest-mcabber-0.9.5
new file mode 100644
index 000000000000..aa1b07ebc1e7
--- /dev/null
+++ b/net-im/mcabber/files/digest-mcabber-0.9.5
@@ -0,0 +1,3 @@
+MD5 69a002038def978689d95b54dc7be9f4 mcabber-0.9.5.tar.bz2 487465
+RMD160 2716471068356512fc08ecf1d5de44fd392810cd mcabber-0.9.5.tar.bz2 487465
+SHA256 cad99f5d1ac132aa4aed4e335a444ff751de840438fafd42544ebd208efe2b7c mcabber-0.9.5.tar.bz2 487465
diff --git a/net-im/mcabber/mcabber-0.9.4.ebuild b/net-im/mcabber/mcabber-0.9.4.ebuild
index b8c0a3c42004..85e50a473a78 100644
--- a/net-im/mcabber/mcabber-0.9.4.ebuild
+++ b/net-im/mcabber/mcabber-0.9.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/mcabber-0.9.4.ebuild,v 1.1 2007/11/19 23:07:59 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/mcabber-0.9.4.ebuild,v 1.2 2007/11/20 00:41:02 wschlich Exp $
DESCRIPTION="A small Jabber console client with various features, like MUC, SSL, PGP"
HOMEPAGE="http://www.lilotux.net/~mikael/mcabber/"
@@ -10,7 +10,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="crypt spell ssl"
+IUSE="crypt otr spell ssl"
LANGS="de en fr nl pl uk ru"
# localized help versions are installed only, when LINGUAS var is set
@@ -20,6 +20,7 @@ done;
DEPEND="ssl? ( >=dev-libs/openssl-0.9.7-r1 )
crypt? ( >=app-crypt/gpgme-1.0.0 )
+ otr? ( net-libs/libotr )
spell? ( app-text/aspell )
>=dev-libs/glib-2.0.0
sys-libs/ncurses"
@@ -27,6 +28,7 @@ DEPEND="ssl? ( >=dev-libs/openssl-0.9.7-r1 )
src_compile() {
econf \
$(use_enable crypt gpgme) \
+ $(use_enable otr) \
$(use_enable spell aspell) \
$(use_with ssl) \
|| die "econf failed"
@@ -35,10 +37,10 @@ src_compile() {
}
src_install() {
- make install DESTDIR=${D} || die "make install failed"
+ make install DESTDIR="${D}" || die "make install failed"
# clean unneeded language documentation
for i in ${LANGS}; do
- ! use linguas_${i} && rm -rf ${D}/usr/share/${PN}/help/${i}
+ ! use linguas_${i} && rm -rf "${D}"/usr/share/${PN}/help/${i}
done
dodoc AUTHORS ChangeLog NEWS README TODO mcabberrc.example
@@ -46,15 +48,15 @@ src_install() {
# contrib themes
insinto /usr/share/${PN}/themes
- doins ${S}/contrib/themes/*
+ doins "${S}"/contrib/themes/*
# contrib generic scripts
exeinto /usr/share/${PN}/scripts
- doexe ${S}/contrib/*.{pl,py,rb}
+ doexe "${S}"/contrib/*.{pl,py,rb}
# contrib event scripts
exeinto /usr/share/${PN}/scripts/events
- doexe ${S}/contrib/events/*
+ doexe "${S}"/contrib/events/*
}
pkg_postinst() {
@@ -72,10 +74,12 @@ pkg_postinst() {
elog
elog "As of MCabber version 0.8.2, there is also a wizard script"
elog "with which you can create all necessary configuration options."
- elog "To use it, simply execute the following command:"
+ elog "To use it, simply execute the following command (please note that you need"
+ elog "to have dev-lang/ruby installed for it to work!):"
elog
elog " ${ROOT}usr/share/${PN}/scripts/mcwizz.rb"
elog
+ elog
elog "See the CONFIGURATION FILE and FILES sections of the mcabber"
elog "manual page (section 1) for more information."
elog
diff --git a/net-im/mcabber/mcabber-0.9.5.ebuild b/net-im/mcabber/mcabber-0.9.5.ebuild
new file mode 100644
index 000000000000..57e73416ce1a
--- /dev/null
+++ b/net-im/mcabber/mcabber-0.9.5.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/mcabber-0.9.5.ebuild,v 1.1 2007/11/20 00:41:02 wschlich Exp $
+
+DESCRIPTION="A small Jabber console client with various features, like MUC, SSL, PGP"
+HOMEPAGE="http://www.lilotux.net/~mikael/mcabber/"
+SRC_URI="http://www.lilotux.net/~mikael/${PN}/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="crypt otr spell ssl"
+
+LANGS="de en fr nl pl uk ru"
+# localized help versions are installed only, when LINGUAS var is set
+for i in ${LANGS}; do
+ IUSE="${IUSE} linguas_${i}"
+done;
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.7-r1 )
+ crypt? ( >=app-crypt/gpgme-1.0.0 )
+ otr? ( net-libs/libotr )
+ spell? ( app-text/aspell )
+ >=dev-libs/glib-2.0.0
+ sys-libs/ncurses"
+
+src_compile() {
+ econf \
+ $(use_enable crypt gpgme) \
+ $(use_enable otr) \
+ $(use_enable spell aspell) \
+ $(use_with ssl) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ # clean unneeded language documentation
+ for i in ${LANGS}; do
+ ! use linguas_${i} && rm -rf "${D}"/usr/share/${PN}/help/${i}
+ done
+
+ dodoc AUTHORS ChangeLog NEWS README TODO mcabberrc.example
+ dodoc doc/README_PGP.txt
+
+ # contrib themes
+ insinto /usr/share/${PN}/themes
+ doins "${S}"/contrib/themes/*
+
+ # contrib generic scripts
+ exeinto /usr/share/${PN}/scripts
+ doexe "${S}"/contrib/*.{pl,py,rb}
+
+ # contrib event scripts
+ exeinto /usr/share/${PN}/scripts/events
+ doexe "${S}"/contrib/events/*
+}
+
+pkg_postinst() {
+ elog
+ elog "MCabber requires you to create a subdirectory .mcabber in your home"
+ elog "directory and to place a configuration file there."
+ elog "An example mcabberrc was installed as part of the documentation."
+ elog "To create a new mcabberrc based on the example mcabberrc, execute the"
+ elog "following commands:"
+ elog
+ elog " mkdir -p ~/.mcabber"
+ elog " bzcat ${ROOT}usr/share/doc/${PF}/mcabberrc.example.bz2 >~/.mcabber/mcabberrc"
+ elog
+ elog "Then edit ~/.mcabber/mcabberrc with your favorite editor."
+ elog
+ elog "As of MCabber version 0.8.2, there is also a wizard script"
+ elog "with which you can create all necessary configuration options."
+ elog "To use it, simply execute the following command (please note that you need"
+ elog "to have dev-lang/ruby installed for it to work!):"
+ elog
+ elog " ${ROOT}usr/share/${PN}/scripts/mcwizz.rb"
+ elog
+ elog
+ elog "See the CONFIGURATION FILE and FILES sections of the mcabber"
+ elog "manual page (section 1) for more information."
+ elog
+ elog "From version 0.9.0 on, MCabber supports PGP encryption of messages."
+ elog "See README_PGP.txt for details."
+ elog
+ elog "Check out ${ROOT}usr/share/${PN} for contributed themes and event scripts."
+ elog
+}