summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/howl')
-rw-r--r--net-misc/howl/ChangeLog7
-rw-r--r--net-misc/howl/howl-0.9.6-r2.ebuild9
-rw-r--r--net-misc/howl/howl-0.9.8.ebuild9
3 files changed, 20 insertions, 5 deletions
diff --git a/net-misc/howl/ChangeLog b/net-misc/howl/ChangeLog
index 7d755bbd831a..84fa54b2eb9c 100644
--- a/net-misc/howl/ChangeLog
+++ b/net-misc/howl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/howl
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/howl/ChangeLog,v 1.21 2005/01/10 01:58:20 stkn Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/howl/ChangeLog,v 1.22 2005/01/22 16:04:18 agriffis Exp $
+
+ 22 Jan 2005; Aron Griffis <agriffis@gentoo.org> howl-0.9.6-r2.ebuild,
+ howl-0.9.8.ebuild:
+ 0.9.6-r2 stable on ia64, repair compilation of 0.9.8 on ia64 with certain
+ versions of linux26-headers
10 Jan 2005; Stefan Knoblich <stkn@gentoo.org> howl-0.9.8.ebuild:
Updated ebuild to preserve old libraries because 0.9.8 introduces a
diff --git a/net-misc/howl/howl-0.9.6-r2.ebuild b/net-misc/howl/howl-0.9.6-r2.ebuild
index ed98a448d420..40686854c285 100644
--- a/net-misc/howl/howl-0.9.6-r2.ebuild
+++ b/net-misc/howl/howl-0.9.6-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/howl/howl-0.9.6-r2.ebuild,v 1.10 2005/01/22 06:06:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/howl/howl-0.9.6-r2.ebuild,v 1.11 2005/01/22 16:04:18 agriffis Exp $
-inherit eutils
+inherit eutils flag-o-matic
DESCRIPTION="Howl is a cross-platform implementation of the Zeroconf networking standard. Zeroconf brings a new ease of use to IP networking."
HOMEPAGE="http://www.porchdogsoft.com/products/howl/"
@@ -22,6 +22,11 @@ src_unpack() {
}
src_compile() {
+ # The following solves compilation using linux26-headers-2.6.8.1-r2 on ia64.
+ # It's not relevant for linux-headers-2.4.x or other linux26-headers, but
+ # won't hurt anything. (21 Jan 2005 agriffis)
+ [[ $ARCH == ia64 ]] && append-flags -D_ASM_IA64_TYPES_H
+
# If we wanted to remove the html docs in /usr/share/howl....
#einfo "Removing html docs from build process...."
#sed -e 's/ docs//' < Makefile.am > Makefile.am.new || die "sed failed"
diff --git a/net-misc/howl/howl-0.9.8.ebuild b/net-misc/howl/howl-0.9.8.ebuild
index 93418aa3fcf0..34ccd821d0c8 100644
--- a/net-misc/howl/howl-0.9.8.ebuild
+++ b/net-misc/howl/howl-0.9.8.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/howl/howl-0.9.8.ebuild,v 1.2 2005/01/10 01:58:20 stkn Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/howl/howl-0.9.8.ebuild,v 1.3 2005/01/22 16:04:18 agriffis Exp $
-inherit eutils
+inherit eutils flag-o-matic
DESCRIPTION="Howl is a cross-platform implementation of the Zeroconf networking standard. Zeroconf brings a new ease of use to IP networking."
HOMEPAGE="http://www.porchdogsoft.com/products/howl/"
@@ -17,6 +17,11 @@ DEPEND="virtual/libc"
# sys-devel/automake - needed if we remove the html docs from /usr/share
src_compile() {
+ # The following solves compilation using linux26-headers-2.6.8.1-r2 on ia64.
+ # It's not relevant for linux-headers-2.4.x or other linux26-headers, but
+ # won't hurt anything. (21 Jan 2005 agriffis)
+ [[ $ARCH == ia64 ]] && append-flags -D_ASM_IA64_TYPES_H
+
# If we wanted to remove the html docs in /usr/share/howl....
#einfo "Removing html docs from build process...."
#sed -e 's/ docs//' < Makefile.am > Makefile.am.new || die "sed failed"