summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/neon/neon-0.24.7.ebuild')
-rw-r--r--net-misc/neon/neon-0.24.7.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/neon/neon-0.24.7.ebuild b/net-misc/neon/neon-0.24.7.ebuild
new file mode 100644
index 000000000000..9bcc8fee80bb
--- /dev/null
+++ b/net-misc/neon/neon-0.24.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.24.7.ebuild,v 1.1 2004/07/20 19:28:55 stuart Exp $
+
+DESCRIPTION="HTTP and WebDAV client library"
+HOMEPAGE="http://www.webdav.org/neon/"
+SRC_URI="http://www.webdav.org/neon/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~s390"
+IUSE="ssl zlib expat"
+
+DEPEND="expat? ( dev-libs/expat )
+ !expat? ( dev-libs/libxml2 )
+ ssl? ( >=dev-libs/openssl-0.9.6f )
+ zlib? ( sys-libs/zlib )"
+
+src_compile() {
+ local myc=""
+ use expat && myc="$myc --with-expat" || myc="$myc --with-xml2"
+ econf \
+ --enable-shared \
+ `use_with ssl` \
+ `use_with zlib` \
+ ${myc} \
+ || die "econf failed"
+ emake
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/*
+}