summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/pymazon')
-rw-r--r--net-misc/pymazon/ChangeLog11
-rw-r--r--net-misc/pymazon/files/amz.xml11
-rw-r--r--net-misc/pymazon/metadata.xml10
-rw-r--r--net-misc/pymazon/pymazon-0.9.ebuild55
4 files changed, 87 insertions, 0 deletions
diff --git a/net-misc/pymazon/ChangeLog b/net-misc/pymazon/ChangeLog
new file mode 100644
index 000000000000..3b7e474abba3
--- /dev/null
+++ b/net-misc/pymazon/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-misc/pymazon
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pymazon/ChangeLog,v 1.1 2010/06/28 16:03:16 lack Exp $
+
+*pymazon-0.9 (28 Jun 2010)
+
+ 28 Jun 2010; Jim Ramsay <lack@gentoo.org> +pymazon-0.9.ebuild,
+ +files/amz.xml, +metadata.xml:
+ Introducing Pymazon-0.9, a graphical open-source replacement for the
+ Amazon.com media downloader (Bug #321599)
+
diff --git a/net-misc/pymazon/files/amz.xml b/net-misc/pymazon/files/amz.xml
new file mode 100644
index 000000000000..8fd3a61d69ae
--- /dev/null
+++ b/net-misc/pymazon/files/amz.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns='http://www.freedesktop.org/standards/shared-mime-info'>
+ <mime-type type="audio/x-amzxml">
+ <sub-class-of type="text/plain"/>
+ <comment>AmazonMP3 Download Queue</comment>
+ <glob pattern="*.amz"/>
+ <magic>
+ <match type="string" offset="0" value="gtBcZ7b78K" />
+ </magic>
+ </mime-type>
+</mime-info>
diff --git a/net-misc/pymazon/metadata.xml b/net-misc/pymazon/metadata.xml
new file mode 100644
index 000000000000..13c3c93a929c
--- /dev/null
+++ b/net-misc/pymazon/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <maintainer>
+ <email>lack@gentoo.org</email>
+ <name>Jim Ramsay</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/net-misc/pymazon/pymazon-0.9.ebuild b/net-misc/pymazon/pymazon-0.9.ebuild
new file mode 100644
index 000000000000..14a70d986c50
--- /dev/null
+++ b/net-misc/pymazon/pymazon-0.9.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pymazon/pymazon-0.9.ebuild,v 1.1 2010/06/28 16:03:16 lack Exp $
+
+EAPI=3
+PYTHON_DEPEND="2"
+inherit eutils distutils fdo-mime
+
+MY_P="Pymazon-${PV}"
+DESCRIPTION="Downloader for the Amazon.com MP3 music store"
+HOMEPAGE="http://code.google.com/p/pymazon/"
+SRC_URI="http://pymazon.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="+gtk +qt4"
+
+DEPEND=""
+DEPEND="gtk? ( dev-python/pygtk )
+ qt4? ( dev-python/PyQt4 )"
+REPEND="${DEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ distutils_src_install
+
+ insinto /usr/share/pixmaps
+ newins pymazon/resource/icons/download.png pymazon.png
+
+ if ! use gtk && ! use qt4; then
+ EXTRA_FIELDS="\nTerminal=true\nNoDisplay=true"
+ DEFAULTARGS=" -c"
+ fi
+ make_desktop_entry "pymazon${DEFAULTARGS}" "Pymazon MP3 Downloader" \
+ pymazon "Network;FileTransfer" \
+ "MimeType=audio/x-amzxml;${EXTRA_FIELDS}"
+
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}/amz.xml"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ einfo "To link pymazon with your amazon.com account, visit:"
+ einfo " http://www.amazon.com/gp/dmusic/after_download_manager_install.html"
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}