summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/gift/gift-0.10.0_pre021004.ebuild')
-rw-r--r--net-p2p/gift/gift-0.10.0_pre021004.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-p2p/gift/gift-0.10.0_pre021004.ebuild b/net-p2p/gift/gift-0.10.0_pre021004.ebuild
new file mode 100644
index 000000000000..9b7a0c95ec5f
--- /dev/null
+++ b/net-p2p/gift/gift-0.10.0_pre021004.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift/gift-0.10.0_pre021004.ebuild,v 1.1 2002/10/05 10:27:33 verwilst Exp $
+
+S=${WORKDIR}/giFT
+DESCRIPTION="Lets you connect to OpenFT, a decentralised p2p network like FastTrack"
+SRC_URI="http://dshieldpy.sourceforge.net/${P}.tgz"
+HOMEPAGE="http://gift.sourceforge.net"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPENDS="virtual/glibc
+ zlib? ( >=sys-libs/zlib-1.1.4 )"
+
+src_compile() {
+
+ cd ${S}
+ ./autogen.sh --prefix=/usr --host=${CHOST} || die
+ emake || die
+
+}
+
+src_install() {
+
+ einstall giftconfdir=${D}/etc/giFT \
+ plugindir=${D}/usr/lib/giFT \
+ giftdatadir=${D}/usr/share/giFT \
+ giftperldir=${D}/usr/bin || die
+ cd ${D}/usr/bin
+ mv giFT-setup giFT-setup.orig
+ sed 's:$prefix/etc/giFT/:/etc/giFT/:' giFT-setup.orig > giFT-setup
+ chmod +x ${D}/usr/bin/giFT-setup
+
+}