summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/broadcom-sta')
-rw-r--r--net-wireless/broadcom-sta/ChangeLog9
-rw-r--r--net-wireless/broadcom-sta/broadcom-sta-5.10.79.10-r3.ebuild47
-rw-r--r--net-wireless/broadcom-sta/files/broadcom-sta-5.10.79.10-linux-2.6.30.patch16
3 files changed, 71 insertions, 1 deletions
diff --git a/net-wireless/broadcom-sta/ChangeLog b/net-wireless/broadcom-sta/ChangeLog
index d3064560a639..1320b8f8b3bf 100644
--- a/net-wireless/broadcom-sta/ChangeLog
+++ b/net-wireless/broadcom-sta/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-wireless/broadcom-sta
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/broadcom-sta/ChangeLog,v 1.3 2009/04/07 16:01:49 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/broadcom-sta/ChangeLog,v 1.4 2009/04/25 01:31:44 matsuu Exp $
+
+*broadcom-sta-5.10.79.10-r3 (25 Apr 2009)
+
+ 25 Apr 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +files/broadcom-sta-5.10.79.10-linux-2.6.30.patch,
+ +broadcom-sta-5.10.79.10-r3.ebuild:
+ 2.6.30 support, bug #248450.
*broadcom-sta-5.10.79.10-r2 (07 Apr 2009)
diff --git a/net-wireless/broadcom-sta/broadcom-sta-5.10.79.10-r3.ebuild b/net-wireless/broadcom-sta/broadcom-sta-5.10.79.10-r3.ebuild
new file mode 100644
index 000000000000..ac420ff87e81
--- /dev/null
+++ b/net-wireless/broadcom-sta/broadcom-sta-5.10.79.10-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/broadcom-sta/broadcom-sta-5.10.79.10-r3.ebuild,v 1.1 2009/04/25 01:31:44 matsuu Exp $
+
+inherit eutils linux-mod versionator
+
+MY_PV="$(replace_all_version_separators _)"
+DESCRIPTION="Broadcom's IEEE 802.11a/b/g/n hybrid Linux device driver."
+HOMEPAGE="http://www.broadcom.com/support/802.11/linux_sta.php"
+SRC_BASE="http://www.broadcom.com/docs/linux_sta/hybrid-portsrc-x86_"
+SRC_URI="x86? ( ${SRC_BASE}32-v${MY_PV}.tar.gz )
+ amd64? ( ${SRC_BASE}64-v${MY_PV}.tar.gz )"
+
+LICENSE="Broadcom"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="mirror"
+
+DEPEND=">=virtual/linux-sources-2.6.22"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+MODULE_NAMES="wl(net/wireless)"
+MODULESD_WL_ALIASES=("wlan0 wl")
+
+pkg_setup() {
+ if kernel_is ge 2 6 29; then
+ CONFIG_CHECK="LIB80211"
+ else
+ CONFIG_CHECK="IEEE80211 IEEE80211_CRYPT_TKIP"
+ fi
+ linux-mod_pkg_setup
+ BUILD_PARAMS="-C ${KV_DIR} M=${S}"
+ BUILD_TARGETS="wl.ko"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch \
+ "${FILESDIR}/${P}-hidden-essid.patch" \
+ "${FILESDIR}/${P}-linux-2.6.29.patch" \
+ "${FILESDIR}/${P}-linux-2.6.30.patch" \
+ "${FILESDIR}/${P}-wl_iw_v2.patch"
+}
diff --git a/net-wireless/broadcom-sta/files/broadcom-sta-5.10.79.10-linux-2.6.30.patch b/net-wireless/broadcom-sta/files/broadcom-sta-5.10.79.10-linux-2.6.30.patch
new file mode 100644
index 000000000000..0427e4ed1f84
--- /dev/null
+++ b/net-wireless/broadcom-sta/files/broadcom-sta-5.10.79.10-linux-2.6.30.patch
@@ -0,0 +1,16 @@
+--- src/wl/sys/wl_linux.c.orig 2009-04-23 21:16:26.637443671 +0400
++++ src/wl/sys/wl_linux.c 2009-04-23 21:17:58.842687327 +0400
+@@ -56,9 +56,13 @@
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 29)
+ #include <net/lib80211.h>
+ #endif
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 30)
++#include <linux/ieee80211.h>
++#else
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 14)
+ #include <net/ieee80211.h>
+ #endif
++#endif
+
+ #include <asm/system.h>
+ #include <asm/io.h>