summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/gnome-bluetooth/gnome-bluetooth-0.5.1-r1.ebuild')
-rw-r--r--net-wireless/gnome-bluetooth/gnome-bluetooth-0.5.1-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-wireless/gnome-bluetooth/gnome-bluetooth-0.5.1-r1.ebuild b/net-wireless/gnome-bluetooth/gnome-bluetooth-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..abf1746c2dc5
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/gnome-bluetooth-0.5.1-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/gnome-bluetooth/gnome-bluetooth-0.5.1-r1.ebuild,v 1.1 2005/01/13 16:30:22 liquidx Exp $
+
+inherit distutils gnome2 eutils
+
+DESCRIPTION="Gnome2 Bluetooth integration suite."
+HOMEPAGE="http://usefulinc.com/software/gnome-bluetooth/"
+SRC_URI="http://downloads.usefulinc.com/gnome-bluetooth/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE=""
+
+RDEPEND=">=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-vfs-2.1.3
+ >=x11-libs/gtk+-2
+ >=gnome-base/librsvg-2
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnome-2
+ >=gnome-base/libbonobo-2
+ >=gnome-base/libbonoboui-2
+ >=gnome-base/gconf-2
+ >=gnome-base/orbit-2
+ >=dev-util/gob-2
+ >=dev-libs/openobex-1
+ >=net-wireless/bluez-libs-2.7
+ >=net-wireless/libbtctl-0.4.1
+ >=dev-python/pygtk-2.0
+ >=dev-python/gnome-python-2"
+
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+DOCS="README NEWS AUTHORS COPYING ChangeLog"
+MAKEOPTS="${MAKEOPTS} -j1"
+PYTHON_MODNAME="gnomebt"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gobcrash.patch
+ epatch ${FILESDIR}/${P}-obex_xfer_rate.patch
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ gnome2_pkg_postrm
+}