summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/mod_auth_mysql')
-rw-r--r--net-www/mod_auth_mysql/ChangeLog8
-rw-r--r--net-www/mod_auth_mysql/Manifest5
-rw-r--r--net-www/mod_auth_mysql/files/digest-mod_auth_mysql-200305101
-rw-r--r--net-www/mod_auth_mysql/mod_auth_mysql-20030510.ebuild39
4 files changed, 49 insertions, 4 deletions
diff --git a/net-www/mod_auth_mysql/ChangeLog b/net-www/mod_auth_mysql/ChangeLog
index a4bcf8643c54..f65d621c328f 100644
--- a/net-www/mod_auth_mysql/ChangeLog
+++ b/net-www/mod_auth_mysql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/mod_auth_mysql
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/ChangeLog,v 1.2 2003/02/12 08:49:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/ChangeLog,v 1.3 2003/05/25 08:31:56 robbat2 Exp $
+
+*mod_auth_mysql-20030510 (25 May 2003)
+
+ 25 May 2003; Robin Johnson <robbat2@gentoo.org>
+ mod_auth_mysql-20030510.ebuild:
+ Version bump, slight fixes to ebuild for updated version.
*mod_auth_mysql-1.11 (28 Nov 2002)
diff --git a/net-www/mod_auth_mysql/Manifest b/net-www/mod_auth_mysql/Manifest
index 6e3f98fc72d6..37b4bb151865 100644
--- a/net-www/mod_auth_mysql/Manifest
+++ b/net-www/mod_auth_mysql/Manifest
@@ -1,7 +1,6 @@
-MD5 738649d24928eebbd6723e8fd951c300 mod_auth_mysql-20030510.ebuild 1091
+MD5 8e0bca0fa63a57ba445fb7fc4fd419a3 mod_auth_mysql-20030510.ebuild 1096
MD5 99cdf565bd91a1f8266d12e64c798e1d mod_auth_mysql-1.11.ebuild 938
-MD5 39533434291d93391b4929070fd49caa ChangeLog 347
-MD5 7df0e9b09422f1a02a59e355116b6ec9 mod_auth_mysql-20030510.ebuild~ 1086
+MD5 8a9395e263901ab00d3b0bdda1c918ae ChangeLog 534
MD5 b6646a117703b3704091e8f19f02e43e tmp/mod_auth_mysql.tgz 9953
MD5 01cc878ba30a6e2ad327de787e21a999 files/12_mod_auth_mysql.conf 3571
MD5 3513e598048c0060eb3758c19c4e4c60 files/digest-mod_auth_mysql-1.11 77
diff --git a/net-www/mod_auth_mysql/files/digest-mod_auth_mysql-20030510 b/net-www/mod_auth_mysql/files/digest-mod_auth_mysql-20030510
new file mode 100644
index 000000000000..7acd1a88ef08
--- /dev/null
+++ b/net-www/mod_auth_mysql/files/digest-mod_auth_mysql-20030510
@@ -0,0 +1 @@
+MD5 b6646a117703b3704091e8f19f02e43e mod_auth_mysql.tgz 9953
diff --git a/net-www/mod_auth_mysql/mod_auth_mysql-20030510.ebuild b/net-www/mod_auth_mysql/mod_auth_mysql-20030510.ebuild
new file mode 100644
index 000000000000..04f779856459
--- /dev/null
+++ b/net-www/mod_auth_mysql/mod_auth_mysql-20030510.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/mod_auth_mysql-20030510.ebuild,v 1.1 2003/05/25 08:31:56 robbat2 Exp $
+
+DESCRIPTION="Basic authentication for Apache using a MySQL database"
+HOMEPAGE="http://modauthmysql.sourceforge.net/"
+
+S=${WORKDIR}/${PN}
+SRC_URI="mirror://sourceforge/modauthmysql/${PN}.tgz"
+DEPEND="dev-db/mysql =net-www/apache-2*"
+LICENSE="Apache-1.1"
+KEYWORDS="~x86"
+IUSE=""
+SLOT="0"
+
+if [ -n "`use apache2`" ]; then
+ APXS="apxs2 -D APACHE2"
+else
+ APXS="apxs -D APACHE1"
+fi
+
+src_compile() {
+ $APXS -c ${PN}.c -I/usr/include/mysql -lmysqlclient -lm -lz || die
+}
+
+src_install() {
+ exeinto /usr/lib/apache2-extramodules
+ doexe .libs/${PN}.so
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/12_mod_auth_mysql.conf
+ cat mod_auth_mysql.c | head -81 \
+ | cut -c 4- > mod_auth_mysql.txt
+ dodoc ${FILESDIR}/12_mod_auth_mysql.conf \
+ README
+}
+
+pkg_postinst() {
+ einfo "Please add '-D AUTH_MYSQL' to your /etc/conf.d/apache2 APACHE2_OPTS setting"
+}