summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/cutg/cutg-150.ebuild')
-rw-r--r--sci-biology/cutg/cutg-150.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sci-biology/cutg/cutg-150.ebuild b/sci-biology/cutg/cutg-150.ebuild
new file mode 100644
index 000000000000..fbb64869f4bf
--- /dev/null
+++ b/sci-biology/cutg/cutg-150.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/cutg/cutg-150.ebuild,v 1.1 2005/12/13 20:00:17 ribosome Exp $
+
+DESCRIPTION="Codon usage tables calculated from GenBank"
+LICENSE="public-domain"
+HOMEPAGE="http://www.kazusa.or.jp/codon/"
+SRC_URI="ftp://ftp.kazusa.or.jp/pub/codon/current/compressed/CUTG.${PV}.tar.gz"
+
+SLOT="0"
+# Minimal build keeps only the indexed files (if applicable) and the
+# documentation. The non-indexed database is not installed.
+IUSE="emboss minimal"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~ppc64 ~x86"
+
+DEPEND="emboss? ( sci-biology/emboss )"
+
+S="${WORKDIR}"
+
+src_compile() {
+ if use emboss; then
+ mkdir CODONS
+ echo
+ einfo "Indexing CUTG for usage with EMBOSS."
+ EMBOSS_DATA="." cutgextract -auto -directory "${S}" || die \
+ "Indexing CUTG failed."
+ echo
+ fi
+}
+
+src_install() {
+ if ! use minimal; then
+ mkdir -p "${D}"usr/share/${PN}
+ mv *.codon *.spsum "${D}"/usr/share/${PN} || die \
+ "Installing raw CUTG database failed."
+ fi
+ dodoc README
+ if use emboss; then
+ mkdir -p "${D}"/usr/share/EMBOSS/data/CODONS
+ cd CODONS
+ for file in *; do
+ mv ${file} "${D}"/usr/share/EMBOSS/data/CODONS || die \
+ "Installing the EMBOSS-indexed database failed."
+ done
+ fi
+}