summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/acpid/ChangeLog8
-rw-r--r--sys-power/acpid/acpid-2.0.11.ebuild5
-rw-r--r--sys-power/acpid/files/acpid-2.0.11-init.d15
3 files changed, 18 insertions, 10 deletions
diff --git a/sys-power/acpid/ChangeLog b/sys-power/acpid/ChangeLog
index 989ca02ce732..20f424c683e1 100644
--- a/sys-power/acpid/ChangeLog
+++ b/sys-power/acpid/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for sys-power/acpid
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/ChangeLog,v 1.70 2011/08/04 18:01:50 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/ChangeLog,v 1.71 2011/08/05 08:47:40 ssuominen Exp $
+
+ 05 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> acpid-2.0.11.ebuild,
+ files/acpid-2.0.11-init.d:
+ Improve init.d script detection of baselayout-1 wrt #270646#c52.
04 Aug 2011; Samuli Suominen <ssuominen@gentoo.org>
files/acpid-2.0.11-init.d:
- Improve init.d script more for baselayout-2.
+ Improve init.d script for baselayout-2.
04 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> -acpid-2.0.6.ebuild,
-acpid-2.0.10.ebuild:
diff --git a/sys-power/acpid/acpid-2.0.11.ebuild b/sys-power/acpid/acpid-2.0.11.ebuild
index 281fc1e2640a..2f3d5c2f1e6b 100644
--- a/sys-power/acpid/acpid-2.0.11.ebuild
+++ b/sys-power/acpid/acpid-2.0.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/acpid-2.0.11.ebuild,v 1.1 2011/08/04 17:01:47 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/acpid-2.0.11.ebuild,v 1.2 2011/08/05 08:47:40 ssuominen Exp $
EAPI=4
inherit eutils systemd toolchain-funcs
@@ -14,6 +14,9 @@ SLOT="0"
KEYWORDS="~amd64 ~ia64 -ppc ~x86"
IUSE=""
+RDEPEND="!<sys-apps/openrc-0.6.0"
+DEPEND=""
+
src_prepare() {
epatch "${FILESDIR}"/${PN}-2.0.3.patch
}
diff --git a/sys-power/acpid/files/acpid-2.0.11-init.d b/sys-power/acpid/files/acpid-2.0.11-init.d
index 444f914dc28e..f7f8139f07fd 100644
--- a/sys-power/acpid/files/acpid-2.0.11-init.d
+++ b/sys-power/acpid/files/acpid-2.0.11-init.d
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/files/acpid-2.0.11-init.d,v 1.5 2011/08/04 18:04:01 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/files/acpid-2.0.11-init.d,v 1.6 2011/08/05 08:47:40 ssuominen Exp $
extra_commands="reload"
command="/usr/sbin/acpid"
@@ -10,16 +10,17 @@ start_stop_daemon_args="--quiet"
description="Daemon for Advanced Configuration and Power Interface"
depend() {
- if [ ! -f /etc/init.d/sysfs ]; then
- eerror "The $SVCNAME init-script is written for baselayout-2!"
- eerror "Please do not use it with baselayout-1!".
- return 1
- fi
-
need localmount
use logger
}
+if [ "${RC_VERSION:-0}" = "0" ]; then
+ start() {
+ eerror "This script cannot be used for baselayout-1."
+ return 1
+ }
+fi
+
reload() {
ebegin "Reloading acpid configuration"
start-stop-daemon --exec $command --signal HUP