summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'virtual/jdk')
-rw-r--r--virtual/jdk/ChangeLog8
-rw-r--r--virtual/jdk/jdk-1.6.0-r1.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/virtual/jdk/ChangeLog b/virtual/jdk/ChangeLog
index 911883025765..c1b4ee923609 100644
--- a/virtual/jdk/ChangeLog
+++ b/virtual/jdk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for virtual/jdk
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/jdk/ChangeLog,v 1.42 2011/11/11 10:54:24 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/jdk/ChangeLog,v 1.43 2011/12/14 09:03:17 sera Exp $
+
+*jdk-1.6.0-r1 (14 Dec 2011)
+
+ 14 Dec 2011; Ralph Sennhauser <sera@gentoo.org> +jdk-1.6.0-r1.ebuild:
+ EAPI bump and simplification.
+ Allow all KEYWORDS including not listed ones to use all VMs. #345319
11 Nov 2011; Vlastimil Babka <caster@gentoo.org> jdk-1.7.0.ebuild:
Add icedtea-bin-7 variant.
diff --git a/virtual/jdk/jdk-1.6.0-r1.ebuild b/virtual/jdk/jdk-1.6.0-r1.ebuild
new file mode 100644
index 000000000000..640f89c224f2
--- /dev/null
+++ b/virtual/jdk/jdk-1.6.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/jdk/jdk-1.6.0-r1.ebuild,v 1.1 2011/12/14 09:03:17 sera Exp $
+
+EAPI="4"
+
+DESCRIPTION="Virtual for JDK"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="1.6"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~ppc-aix ~x86-fbsd ~x64-freebsd ~hppa-hpux ~ia64-hpux ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE=""
+
+# The keyword voodoo below is needed to work around confilcting masking types
+# and for having arch specific preferences.
+# All VMs must be listed in the no use flag enabled case which reflects the
+# default order for amd64 and x86.
+
+# This is that ppc(64) users will get a masked license warning for ibm-jdk-bin
+# instead of (not useful) missing keyword warning for sun-jdk. #287615
+PPC_OPTS="|| (
+ =dev-java/ibm-jdk-bin-1.6.0*
+ =dev-java/icedtea-6* )"
+
+# Prefix defaults - prefer sun-jdk over icedtea
+PREFIX_OPTS="|| (
+ =dev-java/icedtea-bin-6*
+ =dev-java/icedtea-bin-1*
+ =dev-java/sun-jdk-1.6.0* )"
+
+# icedtea-bin-1* is old versioning scheme of icedtea-bin-6*
+RDEPEND="|| (
+ ppc? ( ${PPC_OPTS} )
+ ppc64? ( ${PPC_OPTS} )
+ prefix? ( ${PREFIX_OPTS} )
+ =dev-java/icedtea-bin-6*
+ =dev-java/icedtea-bin-1*
+ =dev-java/icedtea-6*
+ =dev-java/sun-jdk-1.6.0*
+ =dev-java/ibm-jdk-bin-1.6.0*
+ =dev-java/hp-jdk-bin-1.6.0*
+ =dev-java/diablo-jdk-1.6.0*
+ =dev-java/soylatte-jdk-bin-1.0*
+ =dev-java/apple-jdk-bin-1.6.0*
+ =dev-java/winjdk-bin-1.6.0* )"