summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/openmotif/ChangeLog6
-rw-r--r--x11-libs/openmotif/files/openmotif-2.3.2-ldflags.patch24
-rw-r--r--x11-libs/openmotif/openmotif-2.3.2.ebuild3
3 files changed, 31 insertions, 2 deletions
diff --git a/x11-libs/openmotif/ChangeLog b/x11-libs/openmotif/ChangeLog
index 6224870d9ce5..c3eecff38561 100644
--- a/x11-libs/openmotif/ChangeLog
+++ b/x11-libs/openmotif/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/openmotif
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.223 2009/09/25 10:25:47 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.224 2009/11/18 19:12:20 ulm Exp $
+
+ 18 Nov 2009; Ulrich Mueller <ulm@gentoo.org> openmotif-2.3.2.ebuild,
+ +files/openmotif-2.3.2-ldflags.patch:
+ Don't override LDFLAGS, fixes bug 293573.
25 Sep 2009; Ulrich Mueller <ulm@gentoo.org> -openmotif-2.3.0-r3.ebuild,
-files/openmotif-2.3.0-fix-nedit-segfaults.patch,
diff --git a/x11-libs/openmotif/files/openmotif-2.3.2-ldflags.patch b/x11-libs/openmotif/files/openmotif-2.3.2-ldflags.patch
new file mode 100644
index 000000000000..7a84720ea0f5
--- /dev/null
+++ b/x11-libs/openmotif/files/openmotif-2.3.2-ldflags.patch
@@ -0,0 +1,24 @@
+http://bugs.gentoo.org/293573
+
+--- openmotif-2.3.2-orig/lib/Mrm/Makefile.am
++++ openmotif-2.3.2/lib/Mrm/Makefile.am
+@@ -8,7 +8,7 @@
+
+ libMrm_la_LIBADD = ../Xm/libXm.la ${X_LIBS} -lXt ${X_PRE_LIBS} -lX11 ${X_EXTRA_LIBS}
+
+-LDFLAGS = -version-info @CURRENT@:@REVISION@:@AGE@
++AM_LDFLAGS = -version-info @CURRENT@:@REVISION@:@AGE@
+
+ lib_LTLIBRARIES = libMrm.la
+
+--- openmotif-2.3.2-orig/lib/Xm/Makefile.am
++++ openmotif-2.3.2/lib/Xm/Makefile.am
+@@ -11,7 +11,7 @@
+ ${X_CFLAGS}
+ xmdir = $(includedir)/Xm
+
+-LDFLAGS = -version-info @CURRENT@:@REVISION@:@AGE@
++AM_LDFLAGS = -version-info @CURRENT@:@REVISION@:@AGE@
+
+ lib_LTLIBRARIES = libXm.la
+
diff --git a/x11-libs/openmotif/openmotif-2.3.2.ebuild b/x11-libs/openmotif/openmotif-2.3.2.ebuild
index 3d4c34a50d3f..757845c285ec 100644
--- a/x11-libs/openmotif/openmotif-2.3.2.ebuild
+++ b/x11-libs/openmotif/openmotif-2.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.3.2.ebuild,v 1.10 2009/07/13 18:23:17 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.3.2.ebuild,v 1.11 2009/11/18 19:12:20 ulm Exp $
inherit autotools eutils flag-o-matic multilib
@@ -62,6 +62,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}/${PN}-2.3.1-multilist-stipple.patch" #215984
epatch "${FILESDIR}/${PN}-2.3.1-ac-editres.patch" #82081
+ epatch "${FILESDIR}/${P}-ldflags.patch" #293573
# disable compilation of demo binaries
sed -i -e '/^SUBDIRS/{:x;/\\$/{N;bx;};s/[ \t\n\\]*demos//;}' Makefile.am