From 9105207da0f7d5c2674846f47a99baf903903d3b Mon Sep 17 00:00:00 2001
From: Alexey Shvetsov <alexxy@gentoo.org>
Date: Thu, 6 Oct 2011 18:11:13 +0000
Subject: [kde-base] KDE SC 4.7.2

(Portage version: 2.2.0_alpha61/cvs/Linux x86_64)
---
 kde-base/cantor/ChangeLog           |  7 +++++-
 kde-base/cantor/cantor-4.7.2.ebuild | 43 +++++++++++++++++++++++++++++++++++++
 2 files changed, 49 insertions(+), 1 deletion(-)
 create mode 100644 kde-base/cantor/cantor-4.7.2.ebuild

(limited to 'kde-base/cantor')

diff --git a/kde-base/cantor/ChangeLog b/kde-base/cantor/ChangeLog
index 64da96615189..6511d9621b73 100644
--- a/kde-base/cantor/ChangeLog
+++ b/kde-base/cantor/ChangeLog
@@ -1,6 +1,11 @@
 # ChangeLog for kde-base/cantor
 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/ChangeLog,v 1.42 2011/09/07 20:13:42 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/ChangeLog,v 1.43 2011/10/06 18:10:47 alexxy Exp $
+
+*cantor-4.7.2 (06 Oct 2011)
+
+  06 Oct 2011; Alexey Shvetsov <alexxy@gentoo.org> +cantor-4.7.2.ebuild:
+  Version bump KDE SC 4.7.2
 
 *cantor-4.7.1 (07 Sep 2011)
 
diff --git a/kde-base/cantor/cantor-4.7.2.ebuild b/kde-base/cantor/cantor-4.7.2.ebuild
new file mode 100644
index 000000000000..5fefdf1fa33f
--- /dev/null
+++ b/kde-base/cantor/cantor-4.7.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/cantor-4.7.2.ebuild,v 1.1 2011/10/06 18:10:47 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KDE_SCM="git"
+inherit kde4-base
+
+DESCRIPTION="KDE4 interface for doing mathematics and scientific computing"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug ps +R"
+
+# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
+RDEPEND="
+	ps? ( app-text/libspectre )
+	R? ( dev-lang/R )
+"
+DEPEND="${RDEPEND}
+	>=dev-cpp/eigen-2.0.3:2
+"
+
+src_configure() {
+	mycmakeargs+="
+		$(cmake-utils_use_with ps LibSpectre)
+		$(cmake-utils_use_with R)
+	"
+	kde4-base_src_configure
+}
+
+pkg_postinst() {
+	kde4-base_pkg_postinst
+
+	if ! use R; then
+		echo
+		ewarn "You have decided to build ${PN} with no backend."
+		ewarn "To have this application functional, please do one of below:"
+		ewarn "    # emerge -va1 '='${CATEGORY}/${P} with 'R' USE flag enabled"
+		ewarn "    # emerge -vaDu sci-mathematics/maxima"
+		echo
+	fi
+}
-- 
cgit v1.2.3-65-gdbad