From e3ec5b4d19ef5b2ba39441f9957a9749dff98919 Mon Sep 17 00:00:00 2001
From: Jeroen Roovers <jer@gentoo.org>
Date: Wed, 7 Nov 2012 02:57:38 +0000
Subject: Version bump.

(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key A792A613)
---
 net-dns/unbound/ChangeLog             |   7 ++-
 net-dns/unbound/unbound-1.4.18.ebuild | 109 ++++++++++++++++++++++++++++++++++
 2 files changed, 115 insertions(+), 1 deletion(-)
 create mode 100644 net-dns/unbound/unbound-1.4.18.ebuild

(limited to 'net-dns')

diff --git a/net-dns/unbound/ChangeLog b/net-dns/unbound/ChangeLog
index 52e79731a909..672ada3b758e 100644
--- a/net-dns/unbound/ChangeLog
+++ b/net-dns/unbound/ChangeLog
@@ -1,6 +1,11 @@
 # ChangeLog for net-dns/unbound
 # Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/ChangeLog,v 1.44 2012/11/07 02:41:08 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/ChangeLog,v 1.45 2012/11/07 02:57:38 jer Exp $
+
+*unbound-1.4.18 (07 Nov 2012)
+
+  07 Nov 2012; Jeroen Roovers <jer@gentoo.org> +unbound-1.4.18.ebuild:
+  Version bump.
 
 *unbound-1.4.17-r1 (07 Nov 2012)
 
diff --git a/net-dns/unbound/unbound-1.4.18.ebuild b/net-dns/unbound/unbound-1.4.18.ebuild
new file mode 100644
index 000000000000..6291831a6925
--- /dev/null
+++ b/net-dns/unbound/unbound-1.4.18.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/unbound-1.4.18.ebuild,v 1.1 2012/11/07 02:57:38 jer Exp $
+
+EAPI="4"
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-* *-jython"
+
+inherit eutils flag-o-matic python user
+
+DESCRIPTION="A validating, recursive and caching DNS resolver"
+HOMEPAGE="http://unbound.net/"
+SRC_URI="http://unbound.net/downloads/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86 ~x64-macos"
+IUSE="debug gost python selinux static-libs test threads"
+
+RDEPEND="dev-libs/expat
+	dev-libs/libevent
+	>=dev-libs/openssl-0.9.8
+	>=net-libs/ldns-1.6.13[ecdsa,ssl,gost?]
+	selinux? ( sec-policy/selinux-bind )"
+
+DEPEND="${RDEPEND}
+	python? ( dev-lang/swig )
+	test? (
+		net-dns/ldns-utils[examples]
+		dev-util/splint
+		app-text/wdiff
+	)"
+
+# bug #347415
+RDEPEND="${RDEPEND}
+	net-dns/dnssec-root"
+
+pkg_setup() {
+	enewgroup unbound
+	enewuser unbound -1 -1 /etc/unbound unbound
+
+	use python && python_pkg_setup
+}
+
+src_prepare() {
+	# To avoid below error messages, set 'trust-anchor-file' to same value in
+	# 'auto-trust-anchor-file'.
+	# [23109:0] error: Could not open autotrust file for writing,
+	# /etc/dnssec/root-anchors.txt: Permission denied
+	epatch "${FILESDIR}"/${PN}-1.4.12-gentoo.patch
+}
+
+src_configure() {
+	append-ldflags -Wl,-z,noexecstack
+	econf \
+		$(use_enable debug) \
+		$(use_enable gost) \
+		$(use_enable static-libs static) \
+		$(use_with python pythonmodule) \
+		$(use_with python pyunbound) \
+		$(use_with threads pthreads) \
+		--disable-rpath \
+		--enable-ecdsa \
+		--with-ldns="${EPREFIX}"/usr \
+		--with-libevent="${EPREFIX}"/usr \
+		--with-pidfile="${EPREFIX}"/var/run/unbound.pid \
+		--with-rootkey-file="${EPREFIX}"/etc/dnssec/root-anchors.txt
+
+		# http://unbound.nlnetlabs.nl/pipermail/unbound-users/2011-April/001801.html
+		# $(use_enable debug lock-checks) \
+		# $(use_enable debug alloc-checks) \
+		# $(use_enable debug alloc-lite) \
+		# $(use_enable debug alloc-nonregional) \
+}
+
+src_install() {
+	emake DESTDIR="${D}" install || die "emake install failed"
+
+	# bug #299016
+	if use python ; then
+		find "${ED}" -name '_unbound.{la,a}' -delete || die
+	fi
+	if ! use static-libs ; then
+		find "${ED}" -name "*.la" -type f -delete || die
+	fi
+
+	newinitd "${FILESDIR}/unbound.initd" unbound
+	newconfd "${FILESDIR}/unbound.confd" unbound
+
+	dodoc doc/{README,CREDITS,TODO,Changelog,FEATURES}
+
+	# bug #315519
+	dodoc contrib/unbound_munin_
+
+	docinto selinux
+	dodoc contrib/selinux/*
+
+	exeinto /usr/share/${PN}
+	doexe contrib/update-anchor.sh
+}
+
+pkg_postinst() {
+	use python && python_mod_optimize unbound.py unboundmodule.py
+}
+
+pkg_postrm() {
+	use python && python_mod_cleanup unbound.py unboundmodule.py
+}
-- 
cgit v1.2.3-65-gdbad