From 606361636ba8aabf7e9a55dd489620949fb4e573 Mon Sep 17 00:00:00 2001
From: Alex Legler <a3li@gentoo.org>
Date: Sat, 17 Sep 2011 16:10:09 +0000
Subject: Version bump. Change HOMEPAGE and SRC_URI to new upstream. Use new
 configure patch, applied in upstream git.

(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
---
 net-irc/bip/ChangeLog                       | 11 ++++-
 net-irc/bip/bip-0.8.8.ebuild                | 68 +++++++++++++++++++++++++++++
 net-irc/bip/files/bip-0.8.8-configure.patch | 50 +++++++++++++++++++++
 3 files changed, 127 insertions(+), 2 deletions(-)
 create mode 100644 net-irc/bip/bip-0.8.8.ebuild
 create mode 100644 net-irc/bip/files/bip-0.8.8-configure.patch

(limited to 'net-irc')

diff --git a/net-irc/bip/ChangeLog b/net-irc/bip/ChangeLog
index 4bf8f2cf3b5f..70c1542ed802 100644
--- a/net-irc/bip/ChangeLog
+++ b/net-irc/bip/ChangeLog
@@ -1,6 +1,13 @@
 # ChangeLog for net-irc/bip
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/ChangeLog,v 1.19 2010/09/11 13:33:19 a3li Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/ChangeLog,v 1.20 2011/09/17 16:10:09 a3li Exp $
+
+*bip-0.8.8 (17 Sep 2011)
+
+  17 Sep 2011; Alex Legler <a3li@gentoo.org> +bip-0.8.8.ebuild,
+  +files/bip-0.8.8-configure.patch:
+  Version bump. Change HOMEPAGE and SRC_URI to new upstream. Use new configure
+  patch, applied in upstream git.
 
   11 Sep 2010; Alex Legler <a3li@gentoo.org> -bip-0.8.4.ebuild,
   -bip-0.8.5.ebuild:
diff --git a/net-irc/bip/bip-0.8.8.ebuild b/net-irc/bip/bip-0.8.8.ebuild
new file mode 100644
index 000000000000..67117e3f2585
--- /dev/null
+++ b/net-irc/bip/bip-0.8.8.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/bip-0.8.8.ebuild,v 1.1 2011/09/17 16:10:09 a3li Exp $
+
+EAPI="2"
+inherit eutils autotools
+
+DESCRIPTION="Multiuser IRC proxy with SSL support"
+HOMEPAGE="http://bip.milkypond.org/"
+SRC_URI="ftp://ftp.duckcorp.org/bip/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug freenode noctcp ssl vim-syntax oidentd"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}
+	vim-syntax? ( || ( app-editors/vim
+	app-editors/gvim ) )
+	oidentd? ( >=net-misc/oidentd-2.0 )"
+
+src_prepare() {
+	epatch "${FILESDIR}/${P}-configure.patch" || die
+
+	eautoreconf
+
+	if use noctcp; then
+		sed -i -e '/irc_privmsg_check_ctcp(server, line);/s:^://:' src/irc.c || die
+	fi
+
+	if use freenode; then
+		epatch "${FILESDIR}/${PN}-freenode.patch" || die
+	fi
+}
+
+src_configure() {
+	econf \
+		$(use_with ssl openssl) \
+		$(use_enable debug) \
+		$(use_enable oidentd)
+}
+
+src_compile() {
+	# Parallel make fails.
+	emake -j1 || die "emake failed"
+}
+
+src_install() {
+	dobin src/bip src/bipmkpw || die "dobin failed"
+
+	dodoc AUTHORS ChangeLog README NEWS TODO || die "dodoc failed"
+	newdoc samples/bip.conf bip.conf.sample || die "newdoc failed"
+	doman bip.1 bip.conf.5 bipmkpw.1 || die "doman failed"
+
+	if use vim-syntax; then
+		insinto /usr/share/vim/vimfiles/syntax
+		doins samples/bip.vim || die "doins failed"
+		insinto /usr/share/vim/vimfiles/ftdetect
+		doins "${FILESDIR}"/bip.vim || die "doins failed"
+	fi
+}
+
+pkg_postinst() {
+	elog 'The default configuration file is "~/.bip/bip.conf"'
+	elog "You can find a sample configuration file in"
+	elog "/usr/share/doc/${PF}/bip.conf.sample"
+}
diff --git a/net-irc/bip/files/bip-0.8.8-configure.patch b/net-irc/bip/files/bip-0.8.8-configure.patch
new file mode 100644
index 000000000000..592bdc664561
--- /dev/null
+++ b/net-irc/bip/files/bip-0.8.8-configure.patch
@@ -0,0 +1,50 @@
+commit 559fa7ed44238e811ac0c11321ed021c35cba2be
+Author: Pierre-Louis Bonicoli <pierre-louis.bonicoli@gmx.fr>
+Date:   Wed Sep 14 06:30:09 2011 +0200
+
+    don't override user var. Thanks to Alex Legler
+    
+    Based on gentoo-x86/net-irc/bip/files/bip-configure.patch
+    See http://www.gnu.org/software/autoconf/manual/automake.html#User-Variables
+    If user doesn't specify CFLAGS, default value is "-Wall -Wextra -g -O2".
+
+diff --git a/Makefile.am b/Makefile.am
+index c2dae4d..f17c314 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -13,13 +13,8 @@ src_bip_SOURCES = src/conf.y src/lex.l \
+ src_bipmkpw_SOURCES = src/bipmkpw.c src/md5.c src/util.c
+ AM_YFLAGS= -d
+ BUILT_SOURCES = src/conf.c src/conf.h src/lex.c
+-if DEBUG
+-	AM_CFLAGS+=-Wall -g
+-	AM_LDFLAGS+=-g
+-else
+-	AM_CFLAGS+=-Wall
+-endif
+ 
++AM_CFLAGS=-Wall -Wextra
+ 
+ dist_man_MANS = bip.1 bip.conf.5 bipmkpw.1
+ 
+diff --git a/configure.ac b/configure.ac
+index 005e697..5740a39 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -44,16 +44,12 @@ AC_ARG_ENABLE([pie], AS_HELP_STRING([--disable-pie], [Do not build a position in
+ 
+ AM_CONDITIONAL(DEBUG, test x$enable_debug = xyes)
+ AS_IF([test "x$enable_debug" = "xyes"], [
+-	CFLAGS="-O0 -g -W -Wall"
+-	LDFLAGS="-g"
+ 	AC_CHECK_FUNC(backtrace_symbols_fd, [
+ 		AC_DEFINE(HAVE_BACKTRACE, [], [Use glibc backtrace on fatal()])
+ 		LDFLAGS="-rdynamic $LDFLAGS"
+ 		backtrace="(with backtrace)"
+ 	])
+ ], [
+-	CFLAGS="-O2 -g -W -Wall"
+-	LDFLAGS="-g"
+ 	enable_debug=no
+ ])
+ 
-- 
cgit v1.2.3-65-gdbad