summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/xen-tools/xen-tools-3.0.2-r4.ebuild')
-rw-r--r--app-emulation/xen-tools/xen-tools-3.0.2-r4.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/app-emulation/xen-tools/xen-tools-3.0.2-r4.ebuild b/app-emulation/xen-tools/xen-tools-3.0.2-r4.ebuild
index f6fbde1..ac382c5 100644
--- a/app-emulation/xen-tools/xen-tools-3.0.2-r4.ebuild
+++ b/app-emulation/xen-tools/xen-tools-3.0.2-r4.ebuild
@@ -80,13 +80,6 @@ src_unpack() {
-e 's/CFLAGS\(.*\)=\(.*\)-O2\(.*\)/CFLAGS\1=\2\3/' \
-i {} \;
fi
- # for some reason the xen gcc checks don't work on gentoo-hardened
- if use hardened; then
- HARDFLAGS="-nopie -fno-stack-protector -fno-stack-protector-all"
- sed -e "s/CFLAGS :=/CFLAGS := ${HARDFLAGS}/" \
- -i "${S}"/tools/firmware/hvmloader/Makefile \
- "${S}"/tools/firmware/vmxassist/Makefile
- fi
# Disable the 32bit-only vmxassist, if we are not on x86 and we don't support the x86 ABI
if ! use x86 && ! has x86 $(get_all_abis); then
@@ -100,6 +93,10 @@ src_unpack() {
# Allow --as-needed LDFLAGS
epatch "${FILESDIR}/${P}"--as-needed.patch
+ # Allow building with gcc-4.1 (bug #147876)
+ sed -i 's/^CFLAGS += $(call test-gcc-flag,$(CC),-nopie)$/&\nCFLAGS += $(call test-gcc-flag,$(CC),-fnopie)/' \
+ "${S}"/tools/firmware/{hvmloader,vmxassist}/Makefile
+
# Allow building with python-2.5 (bug #149138)
# Backported from upstream - should be in 3.0.3
sed -i 's/\.2|^2\.3|^2\.4/.[2345]/' "${S}"/tools/check/check_python