summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/lucene-analyzers/lucene-analyzers-2.9.4.ebuild')
-rw-r--r--dev-java/lucene-analyzers/lucene-analyzers-2.9.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-java/lucene-analyzers/lucene-analyzers-2.9.4.ebuild b/dev-java/lucene-analyzers/lucene-analyzers-2.9.4.ebuild
new file mode 100644
index 0000000..34aa9ec
--- /dev/null
+++ b/dev-java/lucene-analyzers/lucene-analyzers-2.9.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/lucene-analyzers/lucene-analyzers-2.3.2.ebuild,v 1.5 2010/02/13 16:41:40 grobian Exp $
+
+JAVA_PKG_IUSE="source"
+inherit java-pkg-2 java-ant-2 java-osgi
+
+MY_PN="${PN/lucene-}"
+MY_P="${P/-${MY_PN}}"
+
+DESCRIPTION="Lucene Analyzers additions"
+HOMEPAGE="http://lucene.apache.org/java"
+SRC_URI="mirror://apache/lucene/java/${MY_P}-src.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="2.9"
+KEYWORDS="amd64 ~ia64 ppc x86 ~x86-fbsd ~x86-linux ~amd64-linux ~ppc-macos"
+IUSE=""
+DEPEND=">=virtual/jdk-1.4"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/${MY_P}/contrib/${MY_PN}/common"
+
+src_install() {
+ java-osgi_newjar-fromfile "${WORKDIR}/${MY_P}/build/contrib/${MY_PN}/common/${P}-dev.jar" \
+ "${FILESDIR}/manifest" "Apache Lucene Analysis"
+
+ use source && java-pkg_dosrc "${S}/src/java/org"
+}