aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Zhang <kylerzhang11@gmail.com>2022-12-10 17:35:56 +0800
committerGitHub <noreply@github.com>2022-12-10 15:05:56 +0530
commit228c92eb5c126130316a32b44a0ce8f28cc5d544 (patch)
treedb40c687e70645cbe4d593b3705ddeca0f502692 /Makefile.pre.in
parentgh-100049: fix `repr` for `mappingproxy` in dictionary view example doc (#100... (diff)
downloadcpython-228c92eb5c126130316a32b44a0ce8f28cc5d544.tar.gz
cpython-228c92eb5c126130316a32b44a0ce8f28cc5d544.tar.bz2
cpython-228c92eb5c126130316a32b44a0ce8f28cc5d544.zip
gh-99582: freeze `zipimport` into `_bootstrap_python` (#99583)
Co-authored-by: Kumar Aditya <59607654+kumaraditya303@users.noreply.github.com>
Diffstat (limited to 'Makefile.pre.in')
-rw-r--r--Makefile.pre.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.pre.in b/Makefile.pre.in
index de42d684f16..815df69ad48 100644
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
@@ -976,7 +976,8 @@ Programs/_testembed: Programs/_testembed.o $(LINK_PYTHON_DEPS)
BOOTSTRAP_HEADERS = \
Python/frozen_modules/importlib._bootstrap.h \
- Python/frozen_modules/importlib._bootstrap_external.h
+ Python/frozen_modules/importlib._bootstrap_external.h \
+ Python/frozen_modules/zipimport.h
Programs/_bootstrap_python.o: Programs/_bootstrap_python.c $(BOOTSTRAP_HEADERS) $(PYTHON_HEADERS)