aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-04-01 02:15:48 -0400
committerAndreas K. Hüttel <dilfridge@gentoo.org>2019-01-31 19:16:47 +0100
commit55b00fe1c19ab0f4a27bdc9f0fa5d250d138b1fa (patch)
tree31d575e27c42fc0526a095aa14b4cb30514c5dc9
parentTag 2.29 release (diff)
downloadglibc-55b00fe1c19ab0f4a27bdc9f0fa5d250d138b1fa.tar.gz
glibc-55b00fe1c19ab0f4a27bdc9f0fa5d250d138b1fa.tar.bz2
glibc-55b00fe1c19ab0f4a27bdc9f0fa5d250d138b1fa.zip
Gentoo: disable ldconfig during install
Do not bother running ldconfig on DESTDIR. It's a waste of time as we won't use the result (portage will rebuild the cache after install). Also, the Gentoo sandbox does not currently catch chroot() behavior so we end up (incorrectly) flagging it as a violation as a write to /etc. http://sourceware.org/ml/libc-alpha/2012-08/msg00118.html https://bugs.gentoo.org/431038
-rw-r--r--Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 4a014d6eff..61e254659b 100644
--- a/Makefile
+++ b/Makefile
@@ -107,6 +107,7 @@ install-symbolic-link: subdir_install
rm -f $(symbolic-link-list)
install:
+dont-bother-with-destdir:
-test ! -x $(elf-objpfx)ldconfig || LC_ALL=C \
$(elf-objpfx)ldconfig $(addprefix -r ,$(install_root)) \
$(slibdir) $(libdir)