aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@cardoe.com>2018-08-25 12:01:39 -0500
committerDoug Goldstein <cardoe@cardoe.com>2018-08-26 12:56:14 -0500
commitb20779669e39f229d8d5b9111a61464ddb9a14d7 (patch)
treed320dbf0d1609bf4707a94cfb0cb40575b65559f
parentadd a basic hello world application for testing (diff)
downloadcargo-ebuild-b20779669e39f229d8d5b9111a61464ddb9a14d7.tar.gz
cargo-ebuild-b20779669e39f229d8d5b9111a61464ddb9a14d7.tar.bz2
cargo-ebuild-b20779669e39f229d8d5b9111a61464ddb9a14d7.zip
add ebuild specific metadata to the Cargo.toml
We'll allow upstream packages to specify data fields to help populate ebuilds will the extra data that's necessary to recreate them fully. This adds all possible fields (except depend) for testing. Test data for ref #10.
-rw-r--r--test-crate/Cargo.toml14
1 files changed, 14 insertions, 0 deletions
diff --git a/test-crate/Cargo.toml b/test-crate/Cargo.toml
index 910a22d..09511e8 100644
--- a/test-crate/Cargo.toml
+++ b/test-crate/Cargo.toml
@@ -4,3 +4,17 @@ version = "0.1.0"
authors = ["Doug Goldstein <cardoe@cardoe.com>"]
[dependencies]
+
+[package.metadata.ebuild]
+maintainer = "cargo-ebuild devs <cargo-ebuild@not.a.real>"
+homepage = "http://github.com/cardoe/cargo-ebuild"
+description = "this is an example project"
+license = "MIT"
+restrict = "mirror"
+slot = "0"
+keywords = "amd64"
+iuse = "debug"
+inherit = "eutils"
+depend-is-rdepend = true
+rdepend = "dev-libs/openssl"
+pdepend = "dev-utils/rustfmt"