aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-mobilephone/fsousaged/fsousaged-0.9.1.0.ebuild')
-rw-r--r--sys-mobilephone/fsousaged/fsousaged-0.9.1.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-mobilephone/fsousaged/fsousaged-0.9.1.0.ebuild b/sys-mobilephone/fsousaged/fsousaged-0.9.1.0.ebuild
new file mode 100644
index 0000000..7635c0d
--- /dev/null
+++ b/sys-mobilephone/fsousaged/fsousaged-0.9.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit autotools
+
+DESCRIPTION="freesmartphone.org usage daemon"
+HOMEPAGE="http://www.freesmartphone.org"
+SRC_URI="http://www.freesmartphone.org/sources/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~arm ~x86 ~amd64"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.18.0
+ >=dev-libs/libgee-0.3.0
+ >=media-libs/alsa-lib-1.0.20
+ >=sys-apps/dbus-1.2.1
+ >=dev-libs/dbus-glib-0.76
+ >=sys-mobilephone/libfso-glib-0.2.0
+ >=sys-mobilephone/libfsoframework-0.2.3"
+DEPEND="${RDEPEND}
+ >=dev-lang/vala-0.7.6"
+
+EAPI="2"
+
+src_prepare() {
+ cp "${FILESDIR}"/controller-plugin.vala "${S}"/src/plugins/controller/plugin.vala
+ cp "${FILESDIR}"/lowlevel_kernel26-plugin.vala "${S}"/src/plugins/lowlevel_kernel26/plugin.vala
+ cp "${FILESDIR}"/lowlevel_openmoko-plugin.vala "${S}"/src/plugins/lowlevel_openmoko/plugin.vala
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+}
+
+pkg_postinst() {
+ elog "To use fsousaged instead of ousaged edit the config in"
+ elog "/etc/frameworkd.conf , below the lines where [ousaged] appear make sure"
+ elog "that \"disable 1\" appear. And anywhere add the lines :"
+ elog " [fsousage]"
+ elog " [fsousage.controller]"
+ elog "With this the daemon will be used without any need of initscript."
+}