aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2010-05-30 00:52:28 -0300
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2010-05-30 00:52:28 -0300
commit1da5c68fba1fa51cfad9dfac40f87d65f2eef0a5 (patch)
tree1cc5bde4030af40bf34b60da63a6941aeb2287ec
parentfinished tests/test_ebuild.py; fixed tests/test_description.py and tests/util... (diff)
downloadg-octave-1da5c68fba1fa51cfad9dfac40f87d65f2eef0a5.tar.gz
g-octave-1da5c68fba1fa51cfad9dfac40f87d65f2eef0a5.tar.bz2
g-octave-1da5c68fba1fa51cfad9dfac40f87d65f2eef0a5.zip
Added src_test() to the live ebuild
-rw-r--r--ebuilds/g-octave-9999.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/ebuilds/g-octave-9999.ebuild b/ebuilds/g-octave-9999.ebuild
index df251d7..fe8c1f7 100644
--- a/ebuilds/g-octave-9999.ebuild
+++ b/ebuilds/g-octave-9999.ebuild
@@ -13,7 +13,7 @@ EHG_REPO_URI="http://hg.rafaelmartins.eng.br/g-octave/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE=""
+IUSE="test"
CDEPEND="( >=dev-lang/python-2.6 <dev-lang/python-3 )"
DEPEND="${CDEPEND}
@@ -28,3 +28,7 @@ src_install() {
dohtml ${PN}.html
doman ${PN}.1
}
+
+src_test() {
+ PYTHONPATH=. scripts/run_tests.py || die "test failed."
+}