aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-11-02 17:15:07 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-11-02 17:18:45 +0000
commit71507545eec3031ade9b4f9a314c53216f2c97f2 (patch)
tree4214312ec75554b79133b0dda9f753cace2fa34a
parentBug #378105: UUID/LABEL support for LUKS keydevs (diff)
downloadgenkernel-71507545eec3031ade9b4f9a314c53216f2c97f2.tar.gz
genkernel-71507545eec3031ade9b4f9a314c53216f2c97f2.tar.bz2
genkernel-71507545eec3031ade9b4f9a314c53216f2c97f2.zip
Move to autogenerated ChangeLog.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-rw-r--r--.gitignore1
-rw-r--r--ChangeLog.old (renamed from ChangeLog)4
-rw-r--r--HACKING5
-rw-r--r--Makefile9
4 files changed, 12 insertions, 7 deletions
diff --git a/.gitignore b/.gitignore
index 3f8cb553..5d43ffd4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,3 @@
/genkernel.8
/genkernel-*.tar.bz2
+/ChangeLog
diff --git a/ChangeLog b/ChangeLog.old
index 7902101f..91285650 100644
--- a/ChangeLog
+++ b/ChangeLog.old
@@ -1,9 +1,11 @@
+# After 2012/11/01, the changelog is now auto-generated.
+# This file is for historical purposes only.
# ChangeLog for genkernel
# Copyright:
# - 2003-2008 Gentoo Foundation
# - 2008-2012 Various authors (see AUTHORS)
# Distributed under the GPL v2
-# $Id$
+# $Id: 7902101f65eb47fdc5ed4b116ee234aa23686e1b $
19 Oct 2012; Robin H. Johnson <robbat2@gentoo.org> gen_bootloader.sh:
Missing then keyword.
diff --git a/HACKING b/HACKING
index 479f1aa8..7ac0a60d 100644
--- a/HACKING
+++ b/HACKING
@@ -17,10 +17,9 @@ Testing things:
Rolling a release:
- Bump the version in the main genkernel file.
-- echangelog "Bump version to ${PV}"
-- git commit -a -m "Bump version to ${PV}"
+- git commit -s -a -m "Bump version to ${PV}"
- make dist
-- git tag -a -m "Tag release v${PV}" v${PV}
+- git tag -s -a -m "Tag release v${PV}" v${PV}
- git push ${REMOTE} master --tags
- upload genkernel-${PV}.tar.bz2 to the hosting:
scp genkernel-${PV}.tar.bz2 ${USER}@dev.gentoo.org:/space/distfiles-local/
diff --git a/Makefile b/Makefile
index 751bb462..8e31a066 100644
--- a/Makefile
+++ b/Makefile
@@ -2,20 +2,23 @@ PACKAGE_VERSION = `/bin/fgrep GK_V= genkernel | sed "s/.*GK_V='\([^']\+\)'/\1/"`
distdir = genkernel-$(PACKAGE_VERSION)
# Add off-Git/generated files here that need to be shipped with releases
-EXTRA_DIST = genkernel.8
+EXTRA_DIST = genkernel.8 ChangeLog
genkernel.8: doc/genkernel.8.txt doc/asciidoc.conf Makefile genkernel
a2x --conf-file=doc/asciidoc.conf --attribute="genkernelversion=$(PACKAGE_VERSION)" \
--format=manpage -D . "$<"
+ChangeLog:
+ git log >$@
+
clean:
- rm -f genkernel.8
+ rm -f $(EXTRA_DIST)
check-git-repository:
git diff --quiet || { echo 'STOP, you have uncommitted changes in the working directory' ; false ; }
git diff --cached --quiet || { echo 'STOP, you have uncommitted changes in the index' ; false ; }
-dist: check-git-repository genkernel.8
+dist: check-git-repository $(EXTRA_DIST)
rm -Rf "$(distdir)" "$(distdir)".tar "$(distdir)".tar.bz2
mkdir "$(distdir)"
git ls-files -z | xargs -0 cp --no-dereference --parents --target-directory="$(distdir)" \