aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-10-27 23:48:14 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-10-28 11:10:33 +0200
commitc79cd9c641ed44f48b63f1727ad7ee7c05fa4da2 (patch)
treef18b735412256b615f437550d2e49539b1901958 /app-text
parentsys-libs/kpmcore: Bump subslot (diff)
downloadkde-c79cd9c641ed44f48b63f1727ad7ee7c05fa4da2.tar.gz
kde-c79cd9c641ed44f48b63f1727ad7ee7c05fa4da2.tar.bz2
kde-c79cd9c641ed44f48b63f1727ad7ee7c05fa4da2.zip
app-text/kbibtex: Drop obsolete patch
Package-Manager: Portage-2.3.12, Repoman-2.3.4
Diffstat (limited to 'app-text')
-rw-r--r--app-text/kbibtex/files/kbibtex-system-qtoauth.patch115
-rw-r--r--app-text/kbibtex/kbibtex-9999.ebuild8
2 files changed, 0 insertions, 123 deletions
diff --git a/app-text/kbibtex/files/kbibtex-system-qtoauth.patch b/app-text/kbibtex/files/kbibtex-system-qtoauth.patch
deleted file mode 100644
index b582273743..0000000000
--- a/app-text/kbibtex/files/kbibtex-system-qtoauth.patch
+++ /dev/null
@@ -1,115 +0,0 @@
-commit d5742d770702b60f375139abb4df6f550682dbe8
-Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
-Date: Sun Jan 24 13:04:26 2016 +0100
-
- Re-enable system QtOAuth
-
- This reverts commit ff4b966f13b1b8da8471f92f44751b58012a53e8 and
- partially reverts commit 7b6937326ba2a4e4072692add38a4abd28bd0cd4
- so that kbibtex is using system-qoauth instead of bundled one.
-
- REVIEW: 129927
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index fc73a28c..f5db0bb2 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -165,6 +165,26 @@ endif(
- )
-
- find_package(
-+ QtOAuth
-+)
-+if(
-+ QTOAUTH_FOUND
-+)
-+ add_definitions(
-+ -DHAVE_QTOAUTH
-+ )
-+else(
-+ QTOAUTH_FOUND
-+)
-+ message(
-+ STATUS
-+ "No QtOAuth installed, disabling Zotero OAuth wizard"
-+ )
-+endif(
-+ QTOAUTH_FOUND
-+)
-+
-+find_package(
- Qca-qt5 "2.1.0"
- )
- if (Qca-qt5_FOUND)
-diff --git a/src/networking/CMakeLists.txt b/src/networking/CMakeLists.txt
-index bd16f61e..2e3c4d58 100644
---- a/src/networking/CMakeLists.txt
-+++ b/src/networking/CMakeLists.txt
-@@ -40,12 +40,23 @@ if(BUILD_ZOTERO)
- zotero/collection.cpp
- zotero/items.cpp
- zotero/groups.cpp
-- zotero/oauthwizard.cpp
- zotero/tags.cpp
- zotero/tagmodel.cpp
-- # QOAuth for Qt5 from Git
-- ../3rdparty/qoauth/src/interface.cpp
-+ )
-+ if(
-+ QTOAUTH_FOUND
-+ )
-+ include_directories(
-+ ${QTOAUTH_INCLUDE_DIR}
-+ )
-+ list(
-+ APPEND
-+ kbibtexnetworking_LIB_SRCS
-+ zotero/oauthwizard.cpp
- )
-+ endif(
-+ QTOAUTH_FOUND
-+ )
- endif(BUILD_ZOTERO)
-
- set(
-@@ -90,7 +101,6 @@ if(UNITY_BUILD)
- endif(UNITY_BUILD)
-
- include_directories(
-- ${CMAKE_SOURCE_DIR}/src/3rdparty/qoauth/include
- ${CMAKE_BINARY_DIR}/src/config
- ${CMAKE_SOURCE_DIR}/src/config
- ${CMAKE_BINARY_DIR}/src/data
-@@ -132,9 +142,18 @@ if(BUILD_ZOTERO)
- kbibtexnetworking
- qca-qt5
- )
-+ if(
-+ QTOAUTH_FOUND
-+ )
-+ target_link_libraries(
-+ kbibtexnetworking
-+ ${QTOAUTH_LIBRARY}
-+ )
-+ endif(
-+ QTOAUTH_FOUND
-+ )
- endif(BUILD_ZOTERO)
-
--
- set_target_properties(
- kbibtexnetworking
- PROPERTIES
-diff --git a/src/networking/zotero/oauthwizard.cpp b/src/networking/zotero/oauthwizard.cpp
-index aca03049..7d97886c 100644
---- a/src/networking/zotero/oauthwizard.cpp
-+++ b/src/networking/zotero/oauthwizard.cpp
-@@ -35,7 +35,7 @@
- #include "internalnetworkaccessmanager.h"
- #include "logging_networking.h"
-
--#include <QtOAuth>
-+#include <QtOAuth/QtOAuth>
-
- using namespace Zotero;
-
diff --git a/app-text/kbibtex/kbibtex-9999.ebuild b/app-text/kbibtex/kbibtex-9999.ebuild
index 2fda117464..f48ea59a2b 100644
--- a/app-text/kbibtex/kbibtex-9999.ebuild
+++ b/app-text/kbibtex/kbibtex-9999.ebuild
@@ -60,14 +60,6 @@ RDEPEND="${DEPEND}
S="${WORKDIR}/${P/_/-}"
-PATCHES=( "${FILESDIR}/${PN}-system-qtoauth.patch" )
-
-src_prepare() {
- kde5_src_prepare
-
- rm -r src/3rdparty/qoauth || die "Failed to remove bundled qoauth"
-}
-
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package webengine Qt5WebEngineWidgets)