summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2015-02-03 15:57:59 -0800
committerBrian Dolbec <dolsen@gentoo.org>2015-02-07 12:48:38 -0800
commit9b482adc47992eb2df830d906be57330acc89fa2 (patch)
tree61e79b085023dbe3d8cabe61722cc40e48a8afb8
parentversion bump (diff)
downloadlayman-9b482adc47992eb2df830d906be57330acc89fa2.tar.gz
layman-9b482adc47992eb2df830d906be57330acc89fa2.tar.bz2
layman-9b482adc47992eb2df830d906be57330acc89fa2.zip
Move the plugin module into a portage namespace for installation
But to avoid import conflicts during testing in the checkout, move it to a pm_plugins subdir.
-rw-r--r--MANIFEST.in1
-rw-r--r--pm_plugins/portage/__init__.py0
-rw-r--r--pm_plugins/portage/sync/__init__.py0
-rw-r--r--pm_plugins/portage/sync/modules/__init__.py0
-rw-r--r--pm_plugins/portage/sync/modules/laymansync/__init__.py (renamed from layman/laymanator/__init__.py)4
-rw-r--r--pm_plugins/portage/sync/modules/laymansync/laymansync.py (renamed from layman/laymanator/laymanator.py)0
-rwxr-xr-xsetup.py3
7 files changed, 5 insertions, 3 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index df2a997..b8e8a30 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -12,3 +12,4 @@ include doc/layman.8
include doc/layman.8.html
include doc/layman.8.txt
recursive-include layman/tests *
+recursive-include pm_plugins *
diff --git a/pm_plugins/portage/__init__.py b/pm_plugins/portage/__init__.py
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/pm_plugins/portage/__init__.py
diff --git a/pm_plugins/portage/sync/__init__.py b/pm_plugins/portage/sync/__init__.py
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/pm_plugins/portage/sync/__init__.py
diff --git a/pm_plugins/portage/sync/modules/__init__.py b/pm_plugins/portage/sync/modules/__init__.py
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/pm_plugins/portage/sync/modules/__init__.py
diff --git a/layman/laymanator/__init__.py b/pm_plugins/portage/sync/modules/laymansync/__init__.py
index 890302c..de06b03 100644
--- a/layman/laymanator/__init__.py
+++ b/pm_plugins/portage/sync/modules/laymansync/__init__.py
@@ -19,11 +19,11 @@ except ImportError:
module_spec = {
- 'name': 'laymanator',
+ 'name': 'laymansync',
'description': __doc__,
'provides':{
'layman-module': {
- 'name': 'laymanator',
+ 'name': 'laymansync',
'class': config_class,
'description': __doc__,
'functions': ['sync', 'new', 'exists'],
diff --git a/layman/laymanator/laymanator.py b/pm_plugins/portage/sync/modules/laymansync/laymansync.py
index d5d81ee..d5d81ee 100644
--- a/layman/laymanator/laymanator.py
+++ b/pm_plugins/portage/sync/modules/laymansync/laymansync.py
diff --git a/setup.py b/setup.py
index 8a815eb..21a387a 100755
--- a/setup.py
+++ b/setup.py
@@ -5,6 +5,7 @@ import sys
from distutils.core import setup
+
# this affects the names of all the directories we do stuff with
sys.path.insert(0, './')
from layman.version import VERSION
@@ -27,7 +28,7 @@ SELECTABLE = {
use_defaults = ' '.join(list(SELECTABLE))
SYNC_PLUGINS = {
- 'sync-plugin-portage': 'layman.laymanator',
+ 'sync-plugin-portage': 'portage.sync.modules.laymansync',
}
# get the USE from the environment, default to all selectable modules