aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel J Walsh <dwalsh@redhat.com>2012-09-28 14:11:43 -0400
committerDoug Goldstein <cardoe@cardoe.com>2012-10-05 13:26:16 -0500
commit7f04ae76b5bb09e5bd08994448c5f941c0329f3c (patch)
tree732e552441892cc3b1735bcec5606c2dc3f315a8
parentRelease of libvirt-0.10.2 (diff)
downloadlibvirt-7f04ae76b5bb09e5bd08994448c5f941c0329f3c.tar.gz
libvirt-7f04ae76b5bb09e5bd08994448c5f941c0329f3c.tar.bz2
libvirt-7f04ae76b5bb09e5bd08994448c5f941c0329f3c.zip
build: default selinuxfs mount point to /sys/fs/selinux
Currently if you build on a machine that does not support SELinux we end up with the default mount point being /selinux, since this is moved to /sys/fs/selinux, we should start defaulting there. I believe this is causing a bug in libvirt-lxc when /selinux does not exists, even though /sys/fs/selinux exists.
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 3e9073d28..427212686 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1453,9 +1453,8 @@ fi
if test "$with_selinux" = "yes"; then
AC_MSG_CHECKING([SELinux mount point])
if test "$with_selinux_mount" = "check" || test -z "$with_selinux_mount"; then
- if test -d /sys/fs/selinux ; then
- SELINUX_MOUNT=/sys/fs/selinux
- else
+ SELINUX_MOUNT=/sys/fs/selinux
+ if ! test -d ${SELINUX_MOUNT} && test -d /selinux ; then
SELINUX_MOUNT=/selinux
fi
else