aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2010-11-17 10:38:59 -0700
committerEric Blake <eblake@redhat.com>2010-11-17 11:58:45 -0700
commit38afe8f5ec6f2b3ce917c70b7df3d25c33c7168a (patch)
treef627ebdc9ca1be09a5201dacc87a834fb9ead243 /autobuild.sh
parentdoc: update virsh manual (diff)
downloadlibvirt-38afe8f5ec6f2b3ce917c70b7df3d25c33c7168a.tar.gz
libvirt-38afe8f5ec6f2b3ce917c70b7df3d25c33c7168a.tar.bz2
libvirt-38afe8f5ec6f2b3ce917c70b7df3d25c33c7168a.zip
build: fix autobuild failures on gcov upgrade
Last time I ran ./autobuild.sh was on F13; and upgrading to F14 exposed these leftovers due to a newer gcov than what was in the stale files, in the form of spurious messages that break 'make check': +profiling:/home/remote/eblake/libvirt-tmp/tools/virsh-console.gcda:Version mismatch - expected 405R got 404R and concluding with a bug in the autobuild.sh script itself: ./autobuild.sh: line 44: test: =: unary operator expected * autobuild.sh: avoid syntax error on failed test * tools/Makefile.am (CLEANFILES): Clean coverage files.
Diffstat (limited to 'autobuild.sh')
-rwxr-xr-xautobuild.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/autobuild.sh b/autobuild.sh
index 130f72d41..8248a5954 100755
--- a/autobuild.sh
+++ b/autobuild.sh
@@ -41,7 +41,7 @@ st=$(
{ make check syntax-check 2>&1; echo $? >&4; } | tee "$RESULTS"
)
exec 3>&-
-test $st = 0
+test "$st" = 0
test -x /usr/bin/lcov && make cov
rm -f *.tar.gz