aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel P. Berrange <berrange@redhat.com>2009-07-23 16:07:32 +0100
committerDaniel P. Berrange <berrange@redhat.com>2009-07-23 16:07:32 +0100
commit899ae0d2b52a560ac67104b4ba2f234bfada9df7 (patch)
tree817540e26d58f4189cb4965bf2330f5ecb62448d /autobuild.sh
parentAlways add -no-kvm and -no-kqemu, for qemu domains (diff)
downloadlibvirt-899ae0d2b52a560ac67104b4ba2f234bfada9df7.tar.gz
libvirt-899ae0d2b52a560ac67104b4ba2f234bfada9df7.tar.bz2
libvirt-899ae0d2b52a560ac67104b4ba2f234bfada9df7.zip
Fix misc Win32 compile warnings
GCC >= 4.4 assumes the 'printf' attribute refers to the native runtime libraries format specifiers. Thanks to gnulib, libvirt has GNU format specifiers everywhere. This means we need to use 'gnu_printf' with GCC >= 4.4 to get correct compiler checking of printf format specifiers. * HACKING: Document new rules for ATTRIBUTE_FMT_PRINTF * autobuild.sh, mingw32-libvirt.spec.in: Disable OpenNebula driver on mingw32 builds * qemud/dispatch.h, qemud/qemu.h, src/buf.h src/internal.h, src/logging.h, src/security.h, src/sexpr.h, src/util.h, src/virterror_internal.h, src/xend_internal.c: Change over to ATTRIBUTE_FMT_PRINTF. * src/virsh.c: Disable 'cd' and 'pwd' commands on Win32 since they don't compile * src/threads-win32.c: Add missing return value check
Diffstat (limited to 'autobuild.sh')
-rwxr-xr-xautobuild.sh1
1 files changed, 1 insertions, 0 deletions
diff --git a/autobuild.sh b/autobuild.sh
index 54abede3d..d090e7498 100755
--- a/autobuild.sh
+++ b/autobuild.sh
@@ -76,6 +76,7 @@ if [ -x /usr/bin/i686-pc-mingw32-gcc ]; then
--without-uml \
--without-vbox \
--without-openvz \
+ --without-one \
--without-libvirtd
make