diff options
author | Jim Meyering <meyering@redhat.com> | 2009-12-15 08:27:53 +0100 |
---|---|---|
committer | Jim Meyering <meyering@redhat.com> | 2009-12-15 17:46:04 +0100 |
commit | 5baa463541d9081d43e86237e88d3041b4ae6338 (patch) | |
tree | 35917a34c36c361a96297e084c2d7b5fc97523ae /bootstrap | |
parent | build: update gnulib submodule to latest (diff) | |
download | libvirt-5baa463541d9081d43e86237e88d3041b4ae6338.tar.gz libvirt-5baa463541d9081d43e86237e88d3041b4ae6338.tar.bz2 libvirt-5baa463541d9081d43e86237e88d3041b4ae6338.zip |
avoid malfunction when virFileResolveLink is applied to non-POSIX FS
The virFileResolveLink utility function relied on the POSIX guarantee
that stat.st_size of a symlink is the length of the value. However,
on some types of file systems, it is invalid, so do not rely on it.
Use gnulib's areadlink module instead.
* bootstrap (modules): Add areadlink.
* src/util/util.c: Include "areadlink.h".
Let areadlink perform the readlink and malloc.
* configure.in (AC_CHECK_FUNCS): Remove readlink. No need,
since it's presence is guaranteed by gnulib.
Diffstat (limited to 'bootstrap')
-rwxr-xr-x | bootstrap | 1 |
1 files changed, 1 insertions, 0 deletions
@@ -65,6 +65,7 @@ gnulib_tool=$GNULIB_SRCDIR/gnulib-tool <$gnulib_tool || exit modules=' +areadlink base64 c-ctype close |