aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2009-12-15 08:27:53 +0100
committerJim Meyering <meyering@redhat.com>2009-12-15 17:46:04 +0100
commit5baa463541d9081d43e86237e88d3041b4ae6338 (patch)
tree35917a34c36c361a96297e084c2d7b5fc97523ae /bootstrap
parentbuild: update gnulib submodule to latest (diff)
downloadlibvirt-5baa463541d9081d43e86237e88d3041b4ae6338.tar.gz
libvirt-5baa463541d9081d43e86237e88d3041b4ae6338.tar.bz2
libvirt-5baa463541d9081d43e86237e88d3041b4ae6338.zip
avoid malfunction when virFileResolveLink is applied to non-POSIX FS
The virFileResolveLink utility function relied on the POSIX guarantee that stat.st_size of a symlink is the length of the value. However, on some types of file systems, it is invalid, so do not rely on it. Use gnulib's areadlink module instead. * bootstrap (modules): Add areadlink. * src/util/util.c: Include "areadlink.h". Let areadlink perform the readlink and malloc. * configure.in (AC_CHECK_FUNCS): Remove readlink. No need, since it's presence is guaranteed by gnulib.
Diffstat (limited to 'bootstrap')
-rwxr-xr-xbootstrap1
1 files changed, 1 insertions, 0 deletions
diff --git a/bootstrap b/bootstrap
index 667af4fc8..c07d85158 100755
--- a/bootstrap
+++ b/bootstrap
@@ -65,6 +65,7 @@ gnulib_tool=$GNULIB_SRCDIR/gnulib-tool
<$gnulib_tool || exit
modules='
+areadlink
base64
c-ctype
close